Troubleshooting startup disk, and how to proceed?

Discussion in 'Mac Basics and Help' started by Noeb, Aug 7, 2017.

  1. Noeb macrumors newbie

    Joined:
    Aug 8, 2014
    #1
    Hi! :)

    I have the following setup:

    • Late 2012 (new 2013) iMac. Startup disk is a Samsung EVO SSD 500 GB in a Delock enclosure (externally powered), connected to the iMac via Thunderbolt. The disk is less than 3 years old. Power indicator is on, so it's not a power connection issue.
    • Internal 2 GB HDD, used for storage and files that don't need quick access. I don't think the HDD has a partition that's bootable, but I'm not quite sure.
    • I have updated Time Machine backups of both disks.
    • I have an external disk with a (not so fresh) clone of both the startup disk and the internal disk. I think it's USB 3, and I think it's bootable. Used Carbon Copy Cloner to make it
    Today, when i started the iMac, the "gear" icon was spinning forever. No login window. I restarted (holding the power button), and voila: the flashing folder icon, with a question mark. I assume this means the startup disk wasn't found.

    Tried the following:

    • Hold Shift during startup for Safe Mode: did not work. Only got to the flashing folder/question mark
    • Hold Cmd+R: this works. I get to a menu with options for Time Machine recovery, OSX install, Help/Support and finally Disk Utility. Tried to open Disk Utility - I can only see the internal HDD and in addition some small partition (1.19 GB) called "OSX Home..." or something like that. Verified both without issues. I do not see the SSD.
    So, the question is:

    1: I assume the SSD is dead. Is this reasonable to assume? How can i verify it?
    2: I have a complete and up-to-date Time Machine backup, but I can't start up from it, right?
    3: I guess I could start up from the internal disk - but how (with my setup)? Do I need to delete everything on it first?
    4: My guess is that I will have to get a new SSD, install it into the enclosure, format to Mac OS extended journalled, and then recover backup. And then continue as I have done for the last 3 years. Other suggestions or comments?

    Thanks a lot in advance!!
     
  2. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #2
    It sounds like either the SSD or the enclosure died. No real way to tell which without just swapping out parts. Do you have another external enclosure you can pop the SSD in to see if it works?

    You can option key boot to a Time Machine backup and get to a recovery screen. From there you can use Disk Util to erase the internal drive and restore. That will get you up and running. Of course any data on the internal drive would be erased.
     
  3. chown33 macrumors 604

    Joined:
    Aug 9, 2009
  4. Fishrrman, Aug 7, 2017
    Last edited: Aug 7, 2017

    Fishrrman macrumors G4

    Joined:
    Feb 20, 2009
    #4
    Whenever there's a problem booting -- when you find yourself in an "I can't boot!" moment -- the VERY FIRST THING you should try is to boot from an "alternate" source.

    You've said that you have created cloned backups using CarbonCopyCloner.
    Have you tried booting from your cloned backup yet?

    Before you do anything else, try this:
    1. Locate that USB drive with the CCC cloned backup
    2. Connect it to the Mac
    3. Power up the Mac, and IMMEDIATELY hold down the option key and KEEP HOLDING IT DOWN until the startup manager appears
    4. Do you see the CCC backup volume? If so, select it with the pointer and hit return.
    5. What happens next?

    Do this, and get back to us.
     
  5. Noeb thread starter macrumors newbie

    Joined:
    Aug 8, 2014
    #5
    Thanks a lot people.

    Update - now I'm a little wiser:
    • First of all, the enclosure definitely has power.
    • I tested the disk (in the enclosure) with the same Thunderbolt cable on a Macbook. The power indicator on the enclosure is initially yellow, a little later turns green. The disk shows up in the Finder menu. I can not eject the disk properly (only "forced")
    • Tested once more on the iMac, but another Thunderbolt-port on the iMac. Same as when the problem started: flashing folder icon with question mark. Interesting: the power indicator on the enclosure is yellow, not green.
    • Now I connected to the Macbook again, and ran Disk Utility. Verification of the disk is OK. However, I can not repair ("Error: can not deactivate volume for repair" or something like that)
    • Now I tested the disk with a SATA-USB interface on the Macbook. Disk shows up in Finder. I can now eject properly.
    • Tested the SATA-USB interface on the iMac - interesting: First the folder/question icon flashes for some seconds. Then, VOILA! the iMac boots from the SATA-USB connected SSD disk.
    • Tested one last time with the original enclosure/Thunderbolt cable, nothing happens (only flashing folder/question mark), even if I wait a long time.
    So...Conclusion? I guess the enclosure is the problem. Agree? Any other ideas, or things I should verify/check?

    Thanks once more in advance!
     
  6. chown33 macrumors 604

    Joined:
    Aug 9, 2009
    #6
    I notice you haven't isolated or tested the TB cable separately. So it's logically possible that the enclosure electronics are fine, but the TB cable is not.

    If you try a different cable and it still malfunctions with this enclosure, then that points to the enclosure, especially if the cable under test works on other TB devices (known-good in another situation).

    If it is the enclosure, it could be any component thereof: TB connector, internal cable (if any), internal connector, electronics, etc.
     
  7. Fishrrman macrumors G4

    Joined:
    Feb 20, 2009
    #7
    "Tested the SATA-USB interface on the iMac - interesting: First the folder/question icon flashes for some seconds. Then, VOILA! the iMac boots from the SATA-USB connected SSD disk."

    This is because:
    1. External drive in USB enclosure was not set to be startup drive in "startup disk" preference pane, so...
    2. Mac has to search for bootable volumes at startup (takes a few seconds longer), and then boots from first "bootable" drive it finds.
    (even though the drive is the same drive, the enclosure/connector is different. This can make the difference).

    "I guess the enclosure is the problem. Agree? Any other ideas, or things I should verify/check?"

    IF the SSD boots just fine using the USB enclosure/connector, but DOES NOT boot with the old Thunderbolt enclosure, I'd have to say that YES, it IS the tbolt enclosure.

    Try this:
    Get booted via USB.
    Go to the Startup Disk preference pane and NOW select the USB-connected SSD to be the startup drive.
    Power down -- all the way off.
    Restart.
    Do things go as they should now?

    If they DO, I'd put the Delock thunderbolt enclosure into the closet, and boot via USB, and be happy to do so.
     
  8. Noeb thread starter macrumors newbie

    Joined:
    Aug 8, 2014
    #8
    Tried this minutes ago on the iMac. No luck. So I guess I could be pretty sure it's the enclosure. (Strange though: as earlier mentioned, another Mac "sees" the SSD when connected with the original enclosure and original Thunderbolt-cable. However it cannot be ejected properly).
    --- Post Merged, Aug 9, 2017 ---
    Thanks. Guess I'll put it in the closet, or maybe crush it with a sledgehammer. And buy a USB 3.0 UASP enclosure :)
     

Share This Page