True HORROR story...

Discussion in 'MacBook Pro' started by merl1n, Jul 7, 2008.

  1. merl1n macrumors 65816

    merl1n

    Joined:
    Mar 30, 2008
    Location:
    New Jersey, USA
    #1
    This post Is a bit long so if you don't want to read it, I understand.

    THIS IS A TRUE STORY!

    I have been in the process, over the holiday weekend, of upgrading my sister's MBP from Tiger 10.4.9 to Leopard 10.5.4. Since she needed her computer, I shipped her a portable drive (she lives in CT and I live in NJ and this saves me an entire tank of gas). Remotely I made a clone of her internal drive and had her ship it back to me.

    I made another clone of her cloned drive (in case anything went bad) and connected that to my own MBP and booted from it. It took me about 12 hours of work, updating the OS, dozens of programs, etc. but completed everything OK. I then did a TM backup of it to my TM drive.

    TM Drive background: I backup 3 computers to one 1.5 TB drive using one TM volume. This has been working well for months. I then added my sister's MBP (cloned updated drive connected to my own MBP). I do manual backups frequently.

    Again all went well and the TM backup completed successfully. I then booted back to my own MBP internal disk and disconnected her drive. Ran a TM backup for my own MBP and again all is well. I shutdown for the night.

    NOW THE HORROR STORY BEGINS...

    My MBP setup... "Hellraiser"
    2.33 GHZ 15" 3GB RAM 320GB HD
    Internal Drive set up into 3 partitions:
    "Bloodline" - Boot, programs, home directory (Main Boot Drive)
    "Hellbound" - multimedia files
    "Inferno" - iTunes library, Fusion VMs (Windows XP, Solaris 10)

    Yesterday morning, I added a number of multimedia files to Hellbound. I then decided to run a TM backup. The drive was mounted and I started the backup...it Failed! I tried again and it failed again. I then opened the TM Preferences to see what was going on. I clicked the little icon (warning) and it said it couldn't find the drive??? :confused:

    I went back to the Finder and opened the drive and starting looking at the subdirectories. YIKES, the Hellraiser backups were gone (all of them since April 30th), but the drive space they occupied was still used. :eek:

    So I figured, maybe the folder became invisible. I went into Terminal and looked at the drive. No, the backups were gone, but the space still used. I figured the TM drive had some directory damage so I ran diskutil repairVolume on it. Took about 2 hours, but found no problems??? :confused:

    Ok, now break out the power tools (DiskWarrior aka DW)! ;)

    I ran DW from my boot drive to check out the TM drive. About 30 minutes in, it gave me an error (forget the error number) stating I ran out of memory and to boot from the DW CD. :(

    I rebooted into Safe Boot mode and tried again. Same results.

    So I load the CD and boot from it. I rerun the program.... It freezes about 30 minutes in and I could not reboot or force a reboot, so I had to emergency power off (hold the power button).

    I boot again into Safe Boot... (It gets worse!)

    My entire system seemed sluggish. I launch Activity Monitor and see that syslogd was chewing 85% of my cpu and mount_hfs was using about 20% cpu??? What the heck is going on? (Note, you can't force kill these processes because they will just restart.) I then launch console and take a look at the sylogd log file. It was reporting errors on disk0 slice 4 (Inferno) and that it couldn't mount it and kept retrying.

    I opened a Finder window and there was my SHOCK. :eek: My third partition "Inferno" was not mounted. Now the panic starts to set in since my TM backups were toast. I launch DW and it sees the partition. I run repair on it and it reports that it successfully was able to reconstruct a new directory, but the original was totally damaged and couldn't not be repaired. So I click "Replace" and DW thinks it is successful, but it is not. The partition still won't mount. I run repair again and get the same message. I try it a third time with the same results. On the fourth attempt I select "Preview Mode" and DW mounts the partition "read only" (all this time syslogd and mount_hfs are going nuts slowing everything to a crawl). GREAT! :eek:

    With DW running (and the other cpu process hogs) I was able to copy my data over my network to my other Mac. This took about two hours. I then connected another drive and cloned the other two partitions, just in case.

    After that I tried to reboot, but syslogd wouldn't allow it, so I had to, again, emergency power off. I'm wondering what other damage I'm going to run into when I power up again. I have been at it for 10 hours now without a break.

    I power up, resetting the PRAM and boot Safe Boot mode. To my surprise, Inferno mounted! Activity Monitor showed that syslogd is normal and mount_hfs is no longer running. :D I ran DW to check out all of the partitions, and other than some minor problems, all was well. I then ran OnyX to clean out the logs (they must have been huge since syslogd was constantly writing to it) and all of the cache files.

    I then reboot normally. All is well with the MBP. I mount the TM drive and reformat and partition it into 3 volumes instead of one this time. One for each Mac (not including my sister's this time). Since I didn't want a chance to lose all the work I did on her clone, I made an updated clone of her clone (if you can understand that....:rolleyes: ). I ran a new TM backup of my MBP overnight and just finished the TM backup for my Mac PB.

    The question still remains, what happened originally with the TM drive. The only things I can think of is:
    1. I ran out of inodes (Unix file system pointers) or
    2. TM got confused between my MBP (Hellraiser) and booting from my sisters cloned drive using the same MBP (Hellraiser) in that the machine id would be the same.

    Anyway all is well now.

    Merl1n
     
  2. cloudnine macrumors 6502a

    cloudnine

    Joined:
    Jul 3, 2006
    Location:
    San Francisco, CA
    #2
    Holy Cheeses. That sounds like a huge pain in the butt! At least things are relatively back to normal :/
     
  3. merl1n thread starter macrumors 65816

    merl1n

    Joined:
    Mar 30, 2008
    Location:
    New Jersey, USA
    #3
    Believe me, it was and nerve racking as well.
     
  4. gusious macrumors 65816

    gusious

    Joined:
    Dec 2, 2007
    Location:
    Greece
    #4
    I'm freaked.......................!

    Congrats for solving the problem!!!!
     
  5. Jiddick ExRex macrumors 65816

    Jiddick ExRex

    Joined:
    May 14, 2006
    Location:
    Roskilde, DK
    #5
    I am impressed that you have taken backups so seriously and also happy that it actually meant that you got things working again. Congrats :)
     
  6. phillipjfry macrumors 6502a

    phillipjfry

    Joined:
    Dec 12, 2006
    Location:
    Peace in Plainfield
    #6
    I'm frankly more amazed that you had a full 10 hours to dedicate yourself to this. I can't even get 1 hour to myself for team fortress 2. Let alone something as massive drive corruption of biblical proportions :p
     
  7. merl1n thread starter macrumors 65816

    merl1n

    Joined:
    Mar 30, 2008
    Location:
    New Jersey, USA
    #7
    I've been in the computer field since 1983 supporting customers. I know the importance of backups.
     
  8. merl1n thread starter macrumors 65816

    merl1n

    Joined:
    Mar 30, 2008
    Location:
    New Jersey, USA
    #8
    I like that phrasing. :D

    Thanks.
     
  9. Diggity Dang macrumors newbie

    Joined:
    Dec 25, 2007
    #9
    I'm relieved that you fixed this... mostly 'cause it allowed you to get back on here, where you helped me fix MY problem!!! :D

    For real though, I'm glad you fixed your crazy issues, and thanks again for your help.
     
  10. macworkerbee macrumors 6502

    Joined:
    Jun 14, 2008
    #10
    Wow, where can I learn to do all that stuff? Just in case . . . :eek:
     
  11. merl1n thread starter macrumors 65816

    merl1n

    Joined:
    Mar 30, 2008
    Location:
    New Jersey, USA
    #11
    Thanks and glad I was able to help you. :)
     
  12. merl1n thread starter macrumors 65816

    merl1n

    Joined:
    Mar 30, 2008
    Location:
    New Jersey, USA
    #12
    From Masters like me. :rolleyes:

    Just kidding... :D
     
  13. alphaod macrumors Core

    alphaod

    Joined:
    Feb 9, 2008
    Location:
    NYC
    #13
    I am very confused about what happened to your computer and the Time Machine, but I'm glad everything is back to normal.
     
  14. Edwin V. macrumors newbie

    Joined:
    Sep 20, 2008
    #14
    I've got the very same problem at this moment. About a week ago I tried to make a Time Machine backup after installing iTunes 8.0. Time Machine failed and after that the whole external disk didn't mount right. At first it is visible in the Finder, but after trying to read from it, it suddenly disappears. Running Disk Utilities or DiskWarrior didn't solve the problem, so I thought the disk is broken.

    Today I initialized the disk again and created two partitions for Time Machine and other files, all successfully. Then I tried to create a first backup, but in the process it failed again complaining about the disk not being found. At this point I gave up on the disk, decided to bring it back because it is still under guarantee.

    A few minutes later, Leopard crashes completely, leaving me nothing than a forced reboot. After this, the load is very high, caused by mount_hfs and syslogd. I've got a enormous lag on both the mouse and the keyboard.

    After reading this horror story I managed to backup some important files to CD's, now looking into a solution for the problem. Any suggestions?

    [Edit]
    After rebooting in Safe Boot, mount_hfs and logd are acting normal. Using the external disk is still not possible: browsing with the Finder is ok, but once I do a check the Time Machine partition reports it can't be checked. After this it gets automatically unmounted and isn't usable anymore unless I reconnect the drive. Is the HD broken or is it Leopard that has problems with the TM backup I'm trying to make (e.g. by messing up the structure of the partition?)
     
  15. Firefly2002 macrumors 65816

    Joined:
    Jan 9, 2008
    #15
    Isn't running DW and resetting PRAM pretty much the first steps to any problem?
     

Share This Page