Trying to access Mac from Windows (Ethernet)

Discussion in 'Windows, Linux & Others on the Mac' started by MatuX, Sep 1, 2011.

  1. MatuX macrumors newbie

    Joined:
    Feb 16, 2009
    #1
    Hey guys,

    I can't believe we're in 2011 and this is still SO problematic.

    Changed the security policies, Mac shows up, could access it flawlessly, but then I restarted the computer and now Windows says "You do not have permission to access \\MACBOOKAIR-1548."

    Both computers are correctly configured (otherwise I wouldn't be able to connect 1 minute before)

    If I try to access \\192.168.2.3 (which is my Mac's IP), it WILL ask for a username and password, but what once worked, it's not working anymore.

    Funny thing is that now instead of showing my Mac's username, after I enter it, it suddenly changes it to "PEDDO-PC/Matias Pequeno".
    PEDDO-PC is the name of my computer, so... My guess is that of course, if it prefixes the whole thing with that, my Mac won't recognize the user!

    But that's just my guess... As I said, both computers are correctly configured. On Mac activated SMB on File Sharing, checked my user name, also enabled EnableODiskBrowsing and ODSSupported to access Air's Superdrive, on the Windows, configured Local Policies to send LN & NTLM responses, disabled "force 128-bit encryption" for NTLM SSP.

    As I said, it was working beautifully... Now Windows will just say "You don't have permission to access \\MACBOOKAIR-1548".

    Any ideas?

    ----------

    Also went to the Credential Manager, tried changing the username and password there, no luck. Also tried to remove it, no luck as well.
     
  2. MatuX thread starter macrumors newbie

    Joined:
    Feb 16, 2009
    #2
    Solved...

    Went to the Advanced connections of both Wi-Fi and USB Ethernet on my Macbook's Air, and changed the WINS configuration. Set a different name and used WORKGROUP as the workgroup name.

    Probably this will break in a few minutes or after one of the two computers reboots so I wouldn't take this as a full solution.
     

Share This Page