Trying to connect to friends broadband!!!

jonnyboytv

macrumors newbie
Original poster
Aug 14, 2005
3
0
Please help! I have been using mac for years, but have only just started to try and connect my powerbook to a friends UK broadband connection and its not working. I have taken the IP address, Subnet, Gateway, DHCP and DNS servers details off of their PC and put it into my networks settings but still no joy. How is it when I am in internet cafes I can just plug my laptop in and 'hey presto' but here i am struggling!!! Any help would be sooooo appreciated!!! I am just taking a network cable out of their 'box' supplied by their provider (telewest)!! Is it something to do with the provider???
 

Chundles

macrumors G4
Jul 4, 2005
11,978
422
Have you tried resetting your network settings and just plugging it in? If that doesn't work, try clicking "reset DHCP lease"

The router has to be set to assign IP addresses via DHCP otherwise it won't work.
 

greatdevourer

macrumors 68000
Aug 5, 2005
1,996
0
Are you trying to connect to his computer or his 'net connection? If it's his connection, then don't be suprised, as if he's on it at the same time, then you can't. Even then, iirc, it won't connect, as with broadband, you get your DNS from the account's physical location (eg, mine is 164cmbgsh.cmbg.ntli.com or summat like that)
 

jonnyboytv

macrumors newbie
Original poster
Aug 14, 2005
3
0
Thanks

Will try these things and let you know. I am trying to connect to his router (thats the box that the cat-5 network cable comes out of right?), not his computer; so it should in theory work. Cheers all
 

greatdevourer

macrumors 68000
Aug 5, 2005
1,996
0
Oops, sorry. Completely misread the question :p I thought you meant to do a broadband version of using someone elses dialup account from anywhere. My bad *hits head*
 

jonnyboytv

macrumors newbie
Original poster
Aug 14, 2005
3
0
Help

Finally after years a mac problem that has had be stumped for days. Still no joy!!! I have renewed lease (as suggested) - no joy. When I input the ip address etc manually in the network settings it tells me that status is internet is connected but neither explorer or safari run. Is this a con on th epart of the broadband provider to make me install annouying software!!!! Help me mac fans!
 

mad jew

Moderator emeritus
Apr 3, 2004
32,191
5
Adelaide, Australia
Hmm... Have you tried going through the network preferences and clicking the Assist Me button? It's a guide that walks you through making a connection and fro some reason, I usually have more luck with it than just trying to connect manually. :)
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.