Trying to convert .m4a to .mp3

Discussion in 'Digital Audio' started by imac abuser, Aug 15, 2011.

  1. imac abuser macrumors 6502a

    imac abuser

    Mar 1, 2004
    I used to use switch to convert .m4a to .mp3 but lion won't allow it anymore. Basically I'm trying to take a riff I have and want to post it somewhere online so I can share it on facebook. Any ideas?
  2. treestar macrumors 6502

    Feb 28, 2010
    I'll be very surprised if this isn't possible in iTunes anymore. To do so, change your iTunes Import Settings to Import Using: MP3 Encoder. Open the .m4a in iTunes and secondary click on the track to Create MP3 Version.

    I haven't tested this, but this is the way it has always been.


    XLD is great too.
  3. imac abuser thread starter macrumors 6502a

    imac abuser

    Mar 1, 2004
  4. boymilo macrumors newbie

    Aug 19, 2011
    XLD is no longer functional under Lion. It relies on PowerPC code that is not supported.
  5. imac abuser thread starter macrumors 6502a

    imac abuser

    Mar 1, 2004
    It's like Lion is C0ck Blocking all the stuff get of your DRM high ground good lord
  6. QuarterSwede macrumors G3


    Oct 1, 2005
    Colorado Springs, CO
    iTunes is probably the easiest. The Convert to ... function is quick and easy.
  7. Meicyn macrumors regular


    Dec 22, 2007
    Alternatively, Max works as well. It's generally used to accurately rip music CDs, but it also comes with a fully functional converter supporting all manner of audio formats.
  8. appleguy123 macrumors 604


    Apr 1, 2009
    15 minutes in the future
    Is it protected? If not, here's a video for how to do it I found.

    It worked for me to convert a lot of my audiobooks for my non Apple products.
  9. Lamty macrumors newbie

    Oct 11, 2013
    Some apps can be a better choice. An apps i just picked up, it can convert most kind of audio files, you may try that.
  10. bopajuice Suspended


    Mar 22, 2016
    Dark side of the moon
    just used this method the other day in Sierra. Worked for me. Had to restart iTunes for it to work properly.

Share This Page