Trying to copy Apple Hardware Test to external drive, need help

Discussion in 'macOS' started by celebi23, Jan 10, 2010.

  1. celebi23 macrumors regular

    celebi23

    Joined:
    May 31, 2004
    Location:
    CT
    #1
    Did a search & couldn't find the answers that I'm looking for. Forgive me for the long post, there's some backstory to this problem :rolleyes:

    My MacBook Pro has been acting a little bit weird lately (nothing bad enough to bring to the Apple Store yet) so, I've been getting ready to create an emergency boot disk with 2 partitions:

    *Snow Leopard with various Disk repair software (Disk Utility, TechTool Pro, Disk Warrior, Drive Genius, Data Rescue & Stellar Phoenix, all of which I legally own copies of)
    *Apple Hardware Test (in case I lose my disc or it gets damaged)

    The first one should work just fine. I'm having problems with copying Apple Hardware Test to an external drive.

    I'm got a 15-inch MacBook Pro (Core 2 Duo) & my Mac OS X Install Disc 1 is:
    Mac OS X 10.4.8
    AHT Version 3A116
    Disc Version 1.1
    2Z691-5948-A

    Apparently Apple Hardware Test is on a hidden partition (about 30MB or so) that does not normally mount (except when running AHT). I tried finding the partition using the Terminal command "diskutil list" & it didn't show it. I then tried showing the hidden files & the only thing that I could find were the diagnostics folder, located at: "Mac OS X Install Disc 1/System/Library/CoreServices/.diagnostics"

    A friend mentioned to me that when trying to create a Disk Image of the Mac OS X Install Disc 1 with Disk Utility, I needed to select the parent DVD drive (and not the item listed below as "Mac OS X Install Disc 1), go to File-->New-->Disk Image from Disk 1 & then a complete copy (plus the hidden AHT partition) would be made.

    I've got a 16GB Flash Drive & I tried copying the Disk Image using Carbon Copy Cloner (and later trying the "Restore" option with Disk Utility itself) & it would only boot into the Mac OS X Installer, even after holding down the D key while booting up.

    I thought maybe it didn't like USB so, I tried the same with an external FireWire Drive. Same results. Then a friend mentioned that he found out that Apple hosts (pretty much all) AHT Disk Images on their site:

    http://download.info.apple.com/Apple_Hardware_Test/ + Disk Image file name

    and he also sent along this information too:
    Apple Hardware Test 3A115
    Apple Hardware Test v 3A115 supports MacBook Pro (15-inch Core 2 Duo) only. 2006-10-24 Diagnostics MacBook Pro
    018-2591-A
    4.5 MB

    Apple Hardware Test 3A116
    Apple Hardware Test v 3A116 supports MacBook Pro (17-inch Core 2 Duo) only. 2006-10-24 Diagnostics MacBook Pro
    018-2592-A
    4.5 MB

    So 018-2591-A would turn into "018-2591-A.dmg". Regardless if some of the version information is wrong (I've got a 15-Inch Core 2 Duo & the AHT Version is 3A116), I downloaded both & cloned them to my 2 drives (the USB & the FireWire drives, using Disk Utility & Carbon Copy Cloner) & tried booting from them. Wouldn't boot. All that were on the Disk Images were "/System/Library/CoreServices/.diagnostics". Nothing more. Carbon Copy Cloner gave me this error when cloning them:

    So, here are my 2 questions: has anyone been able to successfully locate, & copy, the hidden Apple Hardware Test partition & clone it to an external drive & run AHT from there?
     
  2. Matthew Yohe macrumors 68020

    Joined:
    Oct 12, 2006
    #2
    You don't need to use Carbon Copy Cloner. Use Disk Utility and "Restore" the DMG to a partition on your drive.

    Then you do have to hold "D" when you reboot.
     
  3. celebi23 thread starter macrumors regular

    celebi23

    Joined:
    May 31, 2004
    Location:
    CT
    #3
    Tried that in Disk Utility. Kept getting the same error over & over: "An error (16) occurred while copying. (Resource busy)."

    edit: Just tried restoring the Mac OS X Install DVD 1.dmg file, to my external Firewire HD, on a different computer & Disk Utility gave me this error now:

    Restore Failure
    Could not find any scan information. The source image needs to be imagescanned before it can be restored.

    If I try mounting the dmg first, I get this error instead:

    Restore Failure
    Could not validate source - Resource temporarily unavailable

    The dmg was a complete copy of the original disc
     
  4. Matthew Yohe macrumors 68020

    Joined:
    Oct 12, 2006
    #4
    You have the image mounted. Eject it.

    So, do what it says. Click on "Images" and then "Scan image for Restore"
     
  5. yashrg macrumors regular

    yashrg

    Joined:
    Feb 21, 2008
    #5
    Upon trying to restore the AHT dmg to my USB drive, it asks me to first erase, and then prompts me that it needs to scan the drive. After I say go ahead and scan, I get the "resource busy" message even when I don't have the image mounted.
     
  6. Belka macrumors newbie

    Joined:
    Aug 31, 2013
    #6
    You must mount .dmg first. Then restore to USB included file.
     

Share This Page