Trying to Downgrade Firmware from 3.1.3 to 3.1.2

Discussion in 'iPod touch' started by lilaznzoul, Mar 4, 2010.

  1. lilaznzoul macrumors newbie

    Joined:
    Mar 3, 2010
    #1
    I am trying to downgrade my iPod Touch 3G firmware from 3.1.3 to 3.1.2 BUT "The iPod 'iPod' could not be restored. This device isn't eligible for the requested build."

    Any ideas?

    iTunes - 9.0.3

    Mac
     
  2. Plutonius macrumors 603

    Plutonius

    Joined:
    Feb 22, 2003
    Location:
    New Hampshire
    #2
    You need to give more information on your iPod Touch for people to answer your question. In general, if you have the newest 32G or 64G Touch, there is nothing you can do to revert it.
     
  3. slomifier macrumors regular

    Joined:
    Mar 25, 2008
    #3
    Plutonius might know something I don't (so sorry if that's the case), but don't you just:

    Obtain a copy of a 2.1.2 firmware
    Go into itunes and plug in your ipod
    Open the ipod tab
    SHIFT-Click the Restore
    Find the 2.1.1 FW
    Open it and let it do its thing?

    I don't know if there was a change in the 32&64gb's, but I've done this before for my 8gb 2g iPod Touch
     
  4. lilaznzoul thread starter macrumors newbie

    Joined:
    Mar 3, 2010
    #4
    Sorry, I have an iPod Touch 32gigs 3G 3.1.3 firmware
    i have jailbroke it before but i had to restore (and update) it in order for me to play the purchased songs on the iPod.

    and also, i'll be sure to try that option. just hopefully it is eligible for the requested build. hahaha

    Plutonius - do you know when the dev team will come out with a jailbreak for 3.1.3 3g 32gigs iPod Touch?
     
  5. shadowbird423 macrumors regular

    shadowbird423

    Joined:
    Sep 8, 2009
    Location:
    Chapel Hill
    #5
    Apple fixed this "security vulnerability" with 3.1 (or something in the 3.x.x series). Anyway, it is now imposible to downgrade an iPod running 3.x.x to a prior firmware unless your ECID SHSH was backed up by Cydia (the iPod had to be previously jailbroken to do this). Even then, the new iPod Touches are invulnerable to this AS WELL. Sorry.. :(
    EDIT: There is no timetable for a Blackra1n/devteam release at the moment. Its probably because of how close 4.0 is to release. They want to save any new exploits until it comes out.
     
  6. lilaznzoul thread starter macrumors newbie

    Joined:
    Mar 3, 2010
    #6
    Wow, so I sound and am basically screwed until the dev team comes out with something new. NICE :D
     
  7. Plutonius macrumors 603

    Plutonius

    Joined:
    Feb 22, 2003
    Location:
    New Hampshire
    #7
    Yep, you can't do it on the newest 32/64G.
     

Share This Page