Trying to fix wifi for Pwned 2G 2.1, need some advice.

Discussion in 'iPhone Tips, Help and Troubleshooting' started by weedy, Oct 18, 2008.

  1. weedy macrumors newbie

    Joined:
    Jan 28, 2008
    #1
    So here's my situation:

    Just yesterday I got an old 2G to test it out.

    When I got it, it was:
    - pwned, had 2.1 on it, I have a suspicion it's been ZiPhoned before.
    - wifi was not working at all - when I went into wifi settings, the search indicator just kept spinning, trying to type in a known network made it attempt joining forever

    What I tried:
    Successive steps of more intrusive pwnage restores:
    1.Simple restore, retaining the old settings
    2.Restore with 3.9->4.6 update
    3.Restore with 3.9->4.6 update, unlock baseband and BootNeuter remaining on system after restore
    4.Used the BootNeuter to attempt flashing first 3.9->4.6 and then FakeBlank.

    Results:
    1.Neither of these 3.9->4.6 or FakeBlank worked in any of the iterations - BootNeuter still says it's 3.9 and FakeBlank off.
    2.In some weird spin the 3.point from above got me wifi working after hard reboot, but it's very weak/unstable however, show only a few of the available networks here and disconnects randomly, now also the phone service became unstable (telling me "No Service" or 1 bar of coverage every now and then).
    3.After doing another attempt to flash FakeBlank and reboot, the wifi is gone again, but if I switch it off in settings and wait some time and switch it back on, it works (in the same weak signal and unstable way as in point 2.) again.


    I thought it'd be good idea to use the advertised wifi fix here:
    http://wikee.iphwn.org/sgold_bootrom:fixwifi
    but:
    1.I can't FakeBlank as indicated before
    2.I can transfer the swifi executable to iPhone using MacFuse and Disk for Iphone.app, but I see no way how to set the required permissions for it
    3.How do I even log into iPhone using SSH if it has no WiFi and therefore no IP address (I only have this USB cable to connect it to my MBP)?

    Everything else would be doable if I just knew how to SSH into my iPhone using USB cable.
    I have set up OpenSSH on iPhone as part of Pwnage restore, but not sure the SSH server/daemon is running since I also see no way to install BossPrefs (which would give option to start that service) unless just copying it into iPhone application folder does the trick (does it?).


    If you can anyhow help me, it'd be greatly appreciated.
    Thanks.
     
  2. weedy thread starter macrumors newbie

    Joined:
    Jan 28, 2008
  3. hendrick macrumors newbie

    Joined:
    Jul 22, 2008
    #3
    You need to have Mobile Terminal (or something similar) on your iPhone. Perhaps you can put it there using MacFuse. (I've just downloaded v1.7.1 but can't check it out as I am still running OS X 10.4.11 and it needs 10.5)

    Once you have it, go to here to see what to do: http://aakash-bapna.blogspot.com/2008/05/iphonesure-shot-fix-for-grayed-wifi.html

    However, I understand that the WiFi fixer 'swifi' was designed to be used with firmware 1.1.4, so you may need to downgrade in order to use it.

    Good luck!
     

Share This Page