Trying to get iTunes to play from my external hard drive library...

Discussion in 'Mac Apps and Mac App Store' started by shaunkerr, Aug 31, 2010.

  1. shaunkerr macrumors newbie

    Joined:
    Aug 29, 2010
    #1
    I have roughly a 35gb iTunes library saved to my external hard drive. Initially, I had the files on my internal, but copied the iTunes folder (like Apple's web site told me to do), and went into preferences and pointed the library to my external. After that, I deleted the files from my internal, and voila, everything was working perfectly.

    However, I turned my computer off, and the next day plugged my external in, and opened iTunes, but there was no library, just the iTunes intro screen. So somewhere along the line, I missed a step I think, just wondering if anyone can help, because I hate having the music on my internal drive.

    Cheers
    Shaun
     
  2. GoCubsGo macrumors Nehalem

    GoCubsGo

    Joined:
    Feb 19, 2005
    #2
    When you turned ... wait why did you turn your mac off? Just put it to sleep.
    But anyway, when you turned it on and plugged in the drive did it mount? It needs to mount fully before you even open iTunes. Next troubleshooting step would be to see about whether or not it is still pointed to that drive. It's pretty crucial that you have that drive mounted though.
     
  3. shaunkerr thread starter macrumors newbie

    Joined:
    Aug 29, 2010
    #3
    Jessica,

    I have to turn it off once or twice a week for a reboot, because I'm on it about 12 hours a day for work. The hard drive was fully mounted, and in preferences, it still says it's pointed towards that library:

    /Volumes/SHAUNSTUFF/iTunes/Itunes Music

    But in iTunes it won't show the library, just the "Music" intro screen. One thing I forgot to mention, there was an error dialog that popped up the day I had this working:

    "unknown error occurred, cannot save library," but I didn't think anything of it because it was working.
     
  4. tbayrgs macrumors 603

    tbayrgs

    Joined:
    Jul 5, 2009
    #4
    Is your music actually present on your external HDD? If so, just not in your actual iTunes library, just add it again to your iTunes library (File>Add to library, I believe). Sounds like something happened during initial load.

    Jessica's point about the drive being mounted is a good one as well. I have my media library stored on an external attached to my Mini and if for any reason it becomes unmounted and i don't realize it when try to use iTunes on either of my computers, iTunes redirects the location of my library back to the initial default folder. I set up my macbook to automatically mount the external over my home network upon startup.
     

Share This Page