Trying to help a friend with CoD4 from the app store...

Discussion in 'Mac and PC Games' started by mac2x, Jan 15, 2011.

  1. mac2x macrumors 65816

    Joined:
    Sep 19, 2009
    #1
    Hi,

    He is running into the multiplayer authentication issue. He is connected to the internet, of course. Single player campaign is unaffected.

    I have searched high and low for a solution, but the only discussions I have found are at Apple's support forums. Needless to say no actual solutions. Has anyone here experienced this? Have you found a solution? If so please post!

    Thanks!
     
  2. mac2x thread starter macrumors 65816

    Joined:
    Sep 19, 2009
    #2
    Interestingly, this just appeared at the top of the CoD4 page in the App Store within the last few hours:
     

    Attached Files:

  3. Christopher_bell macrumors newbie

    Joined:
    Feb 24, 2009
    #3
    COD 4 Multiplayer

    I too have been having the same problems. I have now managed to access Multiplayer by going to Applications > Call of Duty 4 - Modern Warfare > Show Contents > Contents > Call of Duty 4 - Modern Warfare Multiplayer. Not sure why I can't get in via the icon thats put in my dock but… However I have yet to play online as I can't see any servers so if anybody has any thoughts regarding this it would be much appreciated.
     
  4. mac2x thread starter macrumors 65816

    Joined:
    Sep 19, 2009
    #4
    I had that problem when I first got my retail DVD version...it started working suddenly as if by magic. Still no idea why that happened...as a (still learning) programmer I know that disappearing problems aren't good. But I can get online and play so I'm not complaining. :D

    I'm waiting to see what Aspyr has to say about these issues with the Mac App Store version.
     
  5. eXccelMBPgaming macrumors newbie

    Joined:
    Jan 16, 2011
    #5
    Hey I'm mac2x's friend. I tried it and sure enough it worked. THANK YOU THANK YOU THANK YOU! :) :apple:
     
  6. mac2x thread starter macrumors 65816

    Joined:
    Sep 19, 2009
    #6
    We are now trying to get punkbuster working. So far it's been no go (pbsetup can't write the files it needs to), but I noticed something while poking around in the terminal. I am the owner of the game files in my retail dvd version.

    But in his (Mac App Store) version, all the game files (within the application package) are owned by root. Obviously, this is why pbsetup can't do anything. It doesn't ask for an admin password either, so I'm assuming that the game files are intended to be owned by the user himself and not root. I'm thinking that doing a chown on the game files might fix things up.

    Any thoughts?
     
  7. mac2x thread starter macrumors 65816

    Joined:
    Sep 19, 2009
    #7
    We figured it out! If pbsetup gives an error about writing the pb folder, it may be that the application bundle is owned by root.

    In the terminal (copy and paste this EXACTLY):

    Code:
    sudo chown -R $USER /Applications/Call\ of\ Duty\ 4.app/
    Note that sudo requires an admin password. This will NOT be echoed to the screen as you type!

    After doing this, pbsetup ran properly and we are playing on PB enabled servers no problem. :)
     
  8. CocoaTurtle macrumors member

    Joined:
    Jun 7, 2010
    #8
    Thanks for sharing this information! I've been on the fence about purchasing Call Of Duty due to so many reviews in the App Store reporting problems with online play and PunkBuster! Thanks to your information, I've gone a head and brought it! :)

    Cheers!
     
  9. mac2x thread starter macrumors 65816

    Joined:
    Sep 19, 2009
    #9
    Not a problem! I had a feeling that the solution was simple, and it didn't take much digging at all to find out why things weren't working (the application is owned by root).

    Normally, OS X application bundles ARE owned by root and should be left that way.

    But in this case, Punkbuster needs to be able to write in the location where the game data is, and since it (obviously) has no provision to use sudo itself (by asking for your admin password), it follows that the user needs to be the owner in this case. This was obviously an oversight made when the game was packaged for the App Store, but fortunately it is an easy fix in terminal. :)
     
  10. CocoaTurtle macrumors member

    Joined:
    Jun 7, 2010
    #10
    Your right, it was a pretty big oversight when they prepared it for the App Store! You should get this information up on a site somewhere, I'm sure a lot of people would appreciate it!

    I think I've got mine sorted out now using your Terminal command and downloading the PunkBuster setup, although you don't add the game into the PB setup? Just update the PB application and everything seems fine? :)
     
  11. mac2x thread starter macrumors 65816

    Joined:
    Sep 19, 2009
    #11
    I believe you select File > Add Games (and select your game) in pbsetup when you set things up the first time. If all is well it should autoupdate. :)
     
  12. CocoaTurtle macrumors member

    Joined:
    Jun 7, 2010
    #12
    Thanks for the information. I think I must have gone wrong somewhere as when I click to 'Add Game' in the pbsetup it says something like it can't find the application or it doesn't exist. Do you think I should run the Terminal command again, restart and then try again? I have made sure the pbsetup itself is up to date.

    On a side note I've only been kicked out of a server due to PB once and that was before trying your method above. Since then I haven't been kicked :)

    Cheers!
     
  13. mac2x thread starter macrumors 65816

    Joined:
    Sep 19, 2009
    #13
    I think there is a discussion at Apple Support about how to do that, but I can't find the link. It was in their Mac App Store support forum.
     
  14. jamieclayton macrumors newbie

    Joined:
    Mar 7, 2011
    #14
    still not working

    Okay, i TRIED to follow what to do on here. so ill give you guys the info.

    I just bought the game on the APP store and ran it, super excited to play COD4 since my xbox was stolen, but of course, no multiplayer servers.

    I have been doing some research and i downloaded the PunkBuster Setup. i clicked add game. added mine, clicked update. It said it updated. I try the game, still no servers.

    Then i try your stuff, i run terminal. I type in your thing and hit enter.
    It loads this:


    WARNING: Improper use of the sudo command could lead to data loss
    or the deletion of important system files. Please double-check your
    typing when using sudo. Type "man sudo" for more information.

    To proceed, enter your password, or type Ctrl-C to abort.

    i type in my password - hit enter.
    then i reupdate punkbuster (what the heck right) - it said downloading new something. i cant remember, it happened so fast i didnt get to catch it.

    play the game. no servers.

    im running 10.6.6 - MacBook Pro. Any help would be great, this is super frustrating.

    Thanks!
     
  15. mac2x, Mar 7, 2011
    Last edited: Mar 8, 2011

    mac2x thread starter macrumors 65816

    Joined:
    Sep 19, 2009
    #15
    Jamie: Aspyr recently released a patch for the App Store version that fixed the problems with Punkbuster and playing modded servers. Be sure you get that. :)

    [late edit] The warning, BTW, is standard procedure for the first time you use sudo. Nothing to worry about. :)
     
  16. AspyrRyan macrumors member

    Joined:
    Feb 9, 2011
    Location:
    Austin, TX
    #16
    From what we can tell, the no servers in multiplayer issue is appearing on both the PC version and our Mac version. The workaround is to refresh the server list until you see the servers.
     

Share This Page