Trying to install Mavericks - stuck at white screen

Discussion in 'OS X Mavericks (10.9)' started by Vazique, Oct 22, 2013.

  1. Vazique macrumors newbie

    Joined:
    Oct 22, 2013
    #1
    So I'm trying to install OSX Mavericks on my late 2010 Macbook. I downloaded it and followed the instructions, which asked me to restart my computer. I did so, and now I'm stuck at the white screen with the grey apple logo. Why?
     
  2. Velin macrumors 65816

    Velin

    Joined:
    Jul 23, 2008
    Location:
    Hearst Castle
    #2
    Let it install for awhile. The upgrade process can take time. If it continue to hang for a very long time, then you may need to reboot, or do a clean install.
     
  3. Vazique, Oct 22, 2013
    Last edited: Oct 22, 2013

    Vazique thread starter macrumors newbie

    Joined:
    Oct 22, 2013
    #3
    I have been waiting for about an hour or so. Still just a white sceen with a grey apple logo. How do I do a clean install?

    EDIT: Yes, I have tried to reboot it a few times.

    EDIT2: Doesn't seem like I'll be able to do a clean install. I tried to re-install Snow Leopard. I put in my install disc, and my Mac just makes a lot of weird noises before the CD pops out again.
     
  4. Vazique thread starter macrumors newbie

    Joined:
    Oct 22, 2013
  5. Irishcatholic macrumors newbie

    Joined:
    Oct 24, 2013
    #5
    Having the same problem. Will allow me to select the user I want then goes to a white screen with no functions possible. Please help?
     
  6. ColdCase macrumors 68030

    Joined:
    Feb 10, 2008
    Location:
    NH
    #6
    A little late, but I had the same problem and posted on another thread that I ended up hitting restart, came back to white screen, reset PRAM, came back to recovery screen, hit restart and then finished the installation just fine. It was scary but turned out OK.
     

Share This Page