Trying to install Windows 8 through Mavericks / Boot Camp

Discussion in 'Windows, Linux & Others on the Mac' started by Shubbeh, Nov 6, 2013.

  1. Shubbeh macrumors member

    Joined:
    Nov 2, 2013
    #1
    Hello,
    I can't figure this out... I've used Boot Camp countless times to install Windows, but never Windows 8, and never through Mavericks.
    I have a 2012 MBA, a 16 GB USB thumb drive and the official Windows 8 64-bit ISO downloaded straight from Microsoft. It's a full install from MSDN, not an upgrade, and it's not Windows 8.1 either.
    I don't know if it matters, but I upgraded to Mavericks from Mountain Lion, so it was not a clean install of 10.9.

    I went through Boot Camp Assistant to "burn" the ISO to the thumb drive and downloaded the Boot Camp drivers to the thumb drive as well. All the files are there as far as I can tell.

    When I do the last step, i.e. partitioning the SSD to accommodate Windows, that part goes fine, then the laptop reboots (with the thumb drive in the USB port), I get a white screen for a minute or so, then I get a classic DOS screen with the following error message:
    "No bootable device -- Insert boot disk and press any key".

    At that point it seems like the keyboard is actually not working, because pressing any key does nothing (normally on a PC it would retry to find a bootable device and throw up the same error message if it can't find any).
    All I can do at that point is hold the power button down to force the computer to shut down. Then I unplug the thumb drive, power up the computer again and it just fails to boot.

    Still with the USB drive disconnected, if I hold down the Alt/Option button during boot, I can get to the boot manager and pick my OS X partition. If I insert my thumb drive at that point, everything freezes. If I unplug it, everything unfreezes.

    If I select the OS X partition, it boots fine. I can then delete the Windows partition through Boot Camp Assistant as if I was removing Windows, but that's not what I'm trying to do :p

    I've tried both of the laptop's USB ports. Not sure what to do next, but if you have any suggestions, it'd be much appreciated. Let me know if you have any questions!
     
  2. Shubbeh thread starter macrumors member

    Joined:
    Nov 2, 2013
    #2
    Well, I grabbed a different USB drive and put the same Windows 8 ISO on it and it's working fine... are Macs picky about the kind of USB drive I'm supposed to use? I think the drive I was originally using was USB 3.0.
     
  3. xcodeSyn macrumors 6502a

    Joined:
    Nov 25, 2012
    #3
    Thanks for the update and this info could probably help others in the future. I think Boot Camp Assistant is quite sensitive to the hardware components on each Mac, and any deviation from the original hardware could cause potential problems since many items were hard coded in the program. Just go through most threads in this forum and you'd observe all sorts of install problems that people encountered and most of them went unanswered.
     

Share This Page