Trying to move home folder but getting error

Discussion in 'Mac mini' started by jomobco, Apr 3, 2014.

  1. jomobco, Apr 3, 2014
    Last edited: Apr 4, 2014

    jomobco macrumors newbie

    Joined:
    Mar 21, 2013
    Location:
    Denver
    #1
    I've got a mini with 2 SSD drives and I want to move my home folder off of the startup drive. However when I move it and it starts to copy it gets 1/4 of the way done and tells me I don't have permission to move certain folders it's trying to copy. I can't figure out how to figure out what folders they are to change the permission. I'm signed in as an admin and I've done it both logged in under my user and also by creating another admin and trying to move my home folder while logged in under the new admin. I'm on Mavericks 10.9.3

    Any ideas on what I'm doing wrong?

    Thanks,
    John
     
  2. 808? macrumors 6502a

    Joined:
    Aug 4, 2011
    Location:
    Hong Kong
    #2
    System Preferences >Users & Group > unlock to make changes > right click on user you want to change > Advanced Options > Home directory > Choose your new home folder volume.

    The copy over your home folder files. (best to do it from another account)
     
  3. jomobco, Apr 4, 2014
    Last edited: Apr 7, 2014

    jomobco thread starter macrumors newbie

    Joined:
    Mar 21, 2013
    Location:
    Denver
    #3
    I did it from the admin I created and then I didn't have permission for some folders on the new user. The folders I moved were associated with the new admin I created. And the only way this move worked was on a folder by folder basis and not by moving the entire home folder at once. If I moved the whole folder I was back to getting 1/4 of the way through and then getting a permissions error.

    I'm logged back in and moving the folders one by one under my user name.

    I'm also doing a reboot in OS X recovery after switching the home folder re-point in advanced options in users and groups. I read that this resets folder permissions.

    Fingers crossed.

    Edit: It worked going folder by folder instead of the entire home folder at once. I had to input my password multiple times which was why it was hanging when I tried to move the entire filer at once. I've now got my home folder on the second SSD.
     

Share This Page