Trying to restore and update, getting the 'firmware file not compatible' error.

AshtonB95

macrumors newbie
Original poster
Jun 1, 2012
1
0
-iPhone 4
-will be relying on an unlock
-in pwned DFU mode
-5.1, trying to go to 5.1.1 for the new untethered jailbreak
-Not sure whether it's GSM or CDMA, but leaning towards GSM.
-iTunes is on version 10.5.2.11

I plugged it in and pressed 'Restore and Update' in iTunes- it downloads the update and then gives me the error, 'The iPhone 'iPhone' could not be restored because the firmware file is not compatible'.

I've tried downloading IPSW's for 5.1.1 from places like iJailbreak and iClarified as well- it won't take them.

What's up with my iPhone?
 

TriJetHero

macrumors 601
Oct 13, 2010
4,953
141
World
Make sure you have the right IPSW file GSM or CDMA.

You need to make a custom IPSW to preserve your BB for the unlock.

Use redsn0w to do that, download latest redsn0w, go to Extras/Custom IPSW
select the 5.1.1 you downloaded. redsn0w will now make a NO_BB IPSW.

Put your phone in DFU-mode
In iTunes ALT-restore(mac) SHIFT-restore(win) with the NO_BB custom IPSW

after you restored use redsn0w to JB.
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.