TRYING to restore my iPhoto pictures after program crash

Discussion in 'Mac Apps and Mac App Store' started by miamialley, Feb 18, 2011.

  1. miamialley, Feb 18, 2011
    Last edited: Feb 18, 2011

    miamialley macrumors 68030

    miamialley

    Joined:
    Jul 28, 2008
    Location:
    Los Angeles, CA
    #1
    I force quit iPhoto after it seemed to stop working. When I restarted iPhoto, it prompted me to choose a library, though my library should still be showing up. I went through the prompts to select the library to find that it's not there on my HD.

    So, I went to my external HD to select THAT library as my library. Won't load...iPhoto just sits there.

    So I have uninstalled and reinstalled iPhoto 4 times and each time the program doesn't get past the *attached* screen. Sometimes this occurs after I am allowed to select a library and sometimes it doesn't even allow me to select a library and just goes directly to this screen. The CPU during this is doing nothing, running at 1%.

    WTF? Help?

    Edit: Also, Appcleaner won't uninstall iPhoto because it says it's a 'protected program.' I don't feel that I'm completely removing the program when I uninstall.
     

    Attached Files:

  2. miamialley thread starter macrumors 68030

    miamialley

    Joined:
    Jul 28, 2008
    Location:
    Los Angeles, CA
    #2
    Long story short, I had to be sure to clean out all iPhoto files using Appcleaner. Then, I got a fresh install of iPhoto.

    My pictures would not upload due to some file corruption on my external hard drive. I had to go back a few backups and copy and paste the iPhoto folder. This restored everything successfully.
     

Share This Page