Trying to restore old hard drive.

Discussion in 'macOS' started by lionsandwings, Jul 2, 2010.

  1. lionsandwings macrumors newbie

    Joined:
    Aug 27, 2009
    #1
    My internal hard drive failed in my iMac about 3 weeks ago. After several attempts trying to repair the disk, I had a new one installed.

    I then tried to recover the data on the old hard drive (most items, all of the important ones, were backed up). I put the old hard drive into an external hard drive enclosure and have access to the files. The problem is I don't have rights to save or move some of the files I would like to copy to the new internal hard drive.

    I tried disk utility to repair the old hard drive, but get a an error (after verifying it says I have to repair it, try to repair and it says I have an error and to back up the files I can and reformat). I believe part of the hard drive is damaged.

    Is there anyway I can change the rights on the old file so I can save it?
     
  2. MacTech68, Jul 2, 2010
    Last edited: Jul 13, 2011

    MacTech68 macrumors 68000

    MacTech68

    Joined:
    Mar 16, 2008
    Location:
    Australia, Perth
    #2
    If you "Get Info" on the hard drive, look down the bottom of the info window and you should see "Ignore Ownership On This Volume". Make sure it's ticked. Unmount the volume and then remount it.

    However, that doesn't give you access to everything. From the sounds of it, the drive is quite corrupted. If you retrieve files from this drive, be sure to check they aren't corrupted. Your alternative is to purchase something like "Disk Warrior" which allows you to preview changes to the drive (and you can copy files from the preview).

    Edit: if you can't see the "Ignore Ownership On This Volume", click the disclosure triangle next to "Sharing & Permissions" (10.5.x) or "Ownership & Permissions" (10.4.x).
     
  3. Heilage macrumors 68030

    Heilage

    Joined:
    May 1, 2009
    #3
    Quick fix:

    - Open Terminal, make sure you have root access (admin password)
    - sudo chflags -R nouchg /Volumes/*name of drive*/ && sudo chmod -R 777 /Volumes/*name of drive*/

    The last "/" after the name of the drive is important. :)
     

Share This Page