Trying to update SSD Firmware without an optical drive

Discussion in 'MacBook Pro' started by Links77, May 20, 2011.

  1. Links77 macrumors newbie

    Joined:
    Jan 13, 2005
    #1
    Hello clever people, I need some help!

    I have a 2011 13inch MacBook Pro, I moved the stock HDD into the optical bay and put in a Crucial C300 128gb SSD as my startup disk.
    It all went smoothly and works great! except for the documented problem with the C300 where it will freeze up for about 20 seconds every once in a while.

    Crucial have updated their firmware to fix this exact problem so I'd like to update, but to do so I need to burn an iso to a CD and boot from it to update the firmware. This would be fine if I still had an optical drive!

    Can any clever people suggest a way I can apply the firmware update without messing around with the internals of my machine again??

    Any suggestions greatly appreciated!! Thank you :)
     
  2. tamvly macrumors 6502a

    tamvly

    Joined:
    Nov 11, 2007
    #2
    Assuming you still have the optical drive, buy an external enclosure from OWC and attach via USB.
     
  3. JGO macrumors member

    Joined:
    Feb 24, 2009
    #3
    Can't be done. You need to burn the .iso to a cd.

    Borrow/buy an external drive or enclosure, burn your cd, boot from it and update...
     
  4. DustinT macrumors 68000

    DustinT

    Joined:
    Feb 26, 2011
    #4
    Borrowing or buying an external drive would be your best bet. Aren't there options to buy an enclosure for the superdrive? Thats probably your best bet.
     
  5. PackFan macrumors 6502

    PackFan

    Joined:
    Apr 22, 2009
    Location:
    Twin Cities, MN
    #5
    I tried my superdrive put in an external enclosure and a 'regular' external drive...

    Neither would boot up on my 2011 15" Macbook Pro. I had to take the C300 out and put in in an old Macbook with an internal drive - and it updated just fine.
     
  6. tamvly macrumors 6502a

    tamvly

    Joined:
    Nov 11, 2007
    #6
    Wow. That sure puts a big kink in the plan for an external superdrive. Bummer. Wonder why ... seems that this should work just fine?
     
  7. bozz2006 macrumors 68030

    bozz2006

    Joined:
    Aug 24, 2007
    Location:
    Minnesota
    #7
    Don't know if this works or not but you could check into it as well: maybe you have a friend who has a macbook and you could use their computer to burn the iso. And maybe you have a 2.5" ext enclosure which you could put the SSD in, and then use their computer to hook it up to and boot off the disk in their machine.... maybe? I dunno. It's a thought. Anybody know if this will work?
     
  8. Loops macrumors member

    Joined:
    Oct 5, 2010
    #8
    First of all, is the firmware update destructive? This article describes a C300 firmware update that causes the drive to lose all stored data.
     
  9. Links77 thread starter macrumors newbie

    Joined:
    Jan 13, 2005
    #9
    According to Crucial's guidelines the latest update is non-destructive.

    Is there any way of running the update from either the HDD in the optical bay or from a USB stick? Can either of these be bootable?
     
  10. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #10
    I have not tried this myself, but can you use the ISO to create a bootable USB thumb drive and do the upgrade that way?
     
  11. johnnj macrumors 6502a

    Joined:
    Dec 11, 2008
    Location:
    Not here
    #11
    It didn't work for me.

    I burned the iso on another machine and the bootloader on the cd would run, but the linux img wouldn't load.

    I had a similar problem when trying to apply updates to my old Vertex drives. I think I remember reading that the isolinux setup that was used to run the updater wasn't compatible with booting off of USB on a Mac, or something to that effect. I don't think it would matter if it was a USB optical drive or a USB flash drive.

    Just for laughs I tried restoring the iso onto a USB flash drive and Disk Utility wouldn't allow it, complaining that the image couldn't be verified and that it was missing the checksum.

    My drives are running fine, so I'm going to keep rolling with the 006. If I was the OP, I'd just put the Superdrive back in and get the C300 running. If this new fw does in fact solve his particular problem, doing some musical drives would be well worth it.
     
  12. JGO macrumors member

    Joined:
    Feb 24, 2009
    #12

    Unfortunately Macs are very finicky about booting from usb. I tried for a long time to get ubuntu to boot from USB (and firewire) using rEFit - never worked. I have read of one person who got it to work, but it required creating another boot partition the internal drive.

    This guy found a way around the efi issues, but I am not sure if it would work for the OP's purposes.
     
  13. johnnyturbouk macrumors 68000

    johnnyturbouk

    Joined:
    Feb 9, 2011
    Location:
    on the yellow [oled] brick road to tech nirvana.
    #13
    i wonder if i could install linux onto a an expresscard 34 ssd with 32/64 gb flash
    i have a 2011 17" MBP
    - since expresscards are bootable wonder if this would work??
     
  14. Links77 thread starter macrumors newbie

    Joined:
    Jan 13, 2005
    #14
    Thanks

    Thanks for your help guys. It seems there's no easy way to do this without opening up my MBP, so I guess that's what I'll be doing!

    One last question, if I take my SSD out and put it in an old MacBook (I don't really want to put the optical drive back in, that was quite tricky to remove in the first place), can I update the firmware using the MacBook, then put it back in my MacBook Pro? Or is that going to mess stuff up??

    Thanks :)
     

Share This Page