Trying to Update to 2.1...problems ensue

Discussion in 'Jailbreaks and iOS Hacks' started by PhantomofPoker, Oct 3, 2008.

  1. PhantomofPoker macrumors newbie

    Joined:
    Oct 3, 2008
    #1
    I am sorry if this has been covered, because I'm sure it has. However, I can't seem to find out exactly how to fix this so I thought I'd post my specific problem and see if someone could tell me what to do.

    I bought an unlocked iphone off of ebay a few months back. It is a 2nd gen. When I bought it, it was unlocked for iphone 1.1.4 using ziphone. By the time I got it, 2.0 was out so I upgraded to 2.0 using Pwnage. Everything worked great. I then waited until 2.1 came out to decide to fiddle with it. This is where the problem ensued.

    Before I upgraded it, I downloaded iTunes 8. Then I restored my iphone software to 2.1 using itunes. I then created a Pwnage ipsw file for 2.1, put it in DFU and tried to restore. However, it came up with an error message. It has said every error from 6 to 1603 to 1604 to 1 etc etc. At this point it is stuck saying itunes can't activate my sim, yadda yadda yadda. So, then I tried to activate my SIM using the method of putting the #*33....etc method into the emergency keypad. That made it so now my phone company shows up at the top left hand corner with the signal bars and I can call out using the emergency keypad, but I can't access the main phone. Then, I tried using Ziphone and iLiberty+ to try to unlock my phone instead of pwnage. They turn the phone into recovery mode, but both programs get stuck there and never get past that step. I've tried using different usb ports and cables. I've restarted my computer and all three programs many times and restored many times. That is where I'm currently at.

    Can someone explain to me what I can do to fix this error? Would using a different computer help? I have been without my iphone for a week, and would greatly appreciate any help that could be offered. And I'm sorry if this is something obvious that I shouldn't be posting about because it's already been covered. THANKS!
     
  2. rotobadger macrumors 65816

    rotobadger

    Joined:
    Sep 18, 2007
    #2
    Here's what I would suggest:

    First, restore the phone to the factory 2.1 using iTunes.
    Next, download the custom ipsw file for 2.1 (you can try here: http://www.iphone-hacks.com/downloads/file/148)


    Next, follow these directions:

    -Download QuickPWNGUI. (Easy find on Google)
    -Next, get yourself a copy of official 2.0.1 firmware. (Easy find on Google)
    PLEASE NOTE 3G or 2G!

    And also PLEASE have your 2.1 Custom firmware ready too.

    Next step seems to be tricky, but it's extremely easy, just gotta be quick.

    -Start up QuickPWN.exe, go through the initial intorduction and select your OFFICIAL 2.0.1 firmware you downloaded earlier.

    It'll bring up a cmd window. Turn off your iPhone and Enter. Basically it'll tell you of a process of Power/Home and special timing methods. DO NOT SELECT YES JUST YET!

    This is the point where you want to be!

    Open up Task Manager (Ctrl+Shift+Esc -Vista) and highlight "quickpwn.exe".

    Now at this point you go through the method of the Power/Home combo. During this method your screen will turn white, it's during the part where it'll tell you to LET GO OF POWER. As soon as your screen turns white you end process "quickpwn.exe". Your phone will stay will that white screen, thats what we want.

    Thats it! You've done the hard part!

    Now open up iTunes 8 and Shift+restore your Custom Firmware and it'll go pass that nuisance error message




    This process worked perfectly for me. Hope this helps...
     
  3. PhantomofPoker thread starter macrumors newbie

    Joined:
    Oct 3, 2008
    #3
    I should have probably mentioned...I have a Mac. :confused:
     
  4. TheConfuzed1 macrumors 6502a

    Joined:
    Jun 4, 2003
    #4
    Force the iPhone into recovery mode. If you're unsure how to do this, follow the directions on this page.

    Now you're starting over again.

    Rejailbreak.

    You'll lose any data that isn't backed up, but unfortunately, at this point, it doesn't seem that you have a choice.

    For extremely detailed information on jailbreaking with a Mac, check out this website.
     
  5. PhantomofPoker thread starter macrumors newbie

    Joined:
    Oct 3, 2008
    #5
    I've put my iphone in recovery mode and tried to rejailbreak and reunlock many times. I've also used DFU mode. It just ends up showing the error while using pwnage, and in iliberty and ziphone just stays stuck on that step. Then I have to restore using itunes and try all over again.
     
  6. TheConfuzed1 macrumors 6502a

    Joined:
    Jun 4, 2003
    #6
    Wow... I really don't know what to try next.

    The guy at hackthatphone.com says that he does repair service for a fee. Maybe you can contact him.
     
  7. PhantomofPoker thread starter macrumors newbie

    Joined:
    Oct 3, 2008
    #7
    Dang. I suppose I'll have to do that if no one has any other suggestions. Anyone else? Thanks!
     
  8. PhantomofPoker thread starter macrumors newbie

    Joined:
    Oct 3, 2008
    #8
    Well...just a little update. I tried a computer with windows vista doing the same methods. That didnt help at all either.
     
  9. rotobadger macrumors 65816

    rotobadger

    Joined:
    Sep 18, 2007
    #9
    Hmmm...tough problem. Let me ask a couple of questions (forgive me if they are obvious but we should cover everything).

    First, are you sure you've entered DFU mode? You should not see anything on your screen at this point.

    Second, are you still trying to use Ziphone or iLiberty? If so, stop. Neither of these programs are for use with 2.x (I think the last firmware supported was 1.1.4 for these programs).

    I understand you are on a Mac but I would suggest going back to a Windows machine and following the directions I posted earlier. You MUST have the custom 2.1 ipsw file for this process. Again, it worked perfectly for me.

    Just to reiterate: Ziphone and/or iLiberty will NOT work with a 2.x iPhone (however I am pretty sure you can use Ziphone to kick your iPhone into DFU rather that doing it manually).

    Hope this info helps you along a little more...
     

Share This Page