Trying to use terminal for copying folder and contents..

Discussion in 'OS X Yosemite (10.10)' started by GrenadaV, Jan 18, 2015.

  1. GrenadaV macrumors newbie

    Joined:
    Dec 13, 2014
    #1
    HI,
    I am trying to use Terminal to copy (using ditto command) one folder to another folder....I am completely brain dead at present....can can't seem to get the path commands correct. Even using drag adn drop to terminal doesnt work for me and I am an absolute beginner when it comes to these..

    Using drag and drop gives me this...

    ditto /Volumes/TIME\ MACHINE/Backups.backupdb //Volumes/TimeMachine\ 4TB

    On pressing return, I get this...

    ditto: /Volumes/TimeMachine 4TB/.RecoverySets: Permission denied
    ditto: /Volumes/TimeMachine 4TB/.spotlight_repair: Permission denied
    ditto: /Volumes/TimeMachine 4TB/.spotlight_temp: Permission denied
    ditto: /Volumes/TimeMachine 4TB/desktop.ini: Permission denied
    ditto: /Volumes/TimeMachine 4TB/Ross’s iMac: Permission denied

    Copying the time machine backups from one volume to another....I know you will be asking,why not just copy and paste using finder.....tried that on several attemps adn keep getting errors and permission issues, even though I have given myself ultimate permissions...

    Hopefully someone can help?

    Cheers
    Rossco
     
  2. NoBoMac macrumors 6502a

    Joined:
    Jul 1, 2014
    #2
  3. GrenadaV thread starter macrumors newbie

    Joined:
    Dec 13, 2014
    #3
    Hi and thanks for your reply..

    I have done all that, followed it to a tee and I do have admin rights, infact 777 full owner admin etc...

    That is why I was now reverting to use terminal but can't seem to get the path/commands right.

    Cheers
    Rossco
     
  4. tumas macrumors member

    Joined:
    Oct 21, 2014
    #4
    There is still a difference between root and administrator rights. Did you try to use the sudo command for copying the files?
    Another thing is how you got those 777 permission rights? If you did not set those rights for the whole directory recursively, then those errors will appear.

    PS: I am not sure if giving 777 permission rights to a backup is such a good idea.... 777 = everybody can read/write/execute those files.
     
  5. leman macrumors 604

    Joined:
    Oct 14, 2008
    #5
    As tumas says, try with sudo. And don't mess up with the permissions, that is a sure way to render your backup inoperable.
     
  6. NoBoMac macrumors 6502a

    Joined:
    Jul 1, 2014
    #6
    What others have said.

    And judging from the error message, no permission to the destination folders. So, could be original not fully open and destination is getting (preserving) original permissions.
     
  7. GrenadaV, Jan 20, 2015
    Last edited: Jan 20, 2015

    GrenadaV thread starter macrumors newbie

    Joined:
    Dec 13, 2014
    #7
    Hi tumas & others...., I couldn't agree more re the 777 rights and have changed them back as soon as I finished (although still not successful) I haven't tried and don't understand the sudo option...

    tumaas, in answer to your question, I changed my rights using PathFinder, really easy to achieve with that app....(good thing/bad thing) maybe but it works...

    I have only been having these problems since upgrading/clean install of Yosemite, so I think I will roll back to Mavericks.....just spending to much time on this sort of thing..

    Cheers
    Rossco
     
  8. tumas macrumors member

    Joined:
    Oct 21, 2014
    #8
    Well i do not know pathfinder, but

    Code:
    sudo ditto /Volumes/TIME\ MACHINE/Backups.backupdb /Volumes/TimeMachine\ 4TB/ 
    
    would probably work. If you are still running Yosemite you can try it and post the result here.

    tumas
     
  9. GrenadaV thread starter macrumors newbie

    Joined:
    Dec 13, 2014
    #9
    Hi again,

    Didnt get to use that script as finally managed to recover the time machine from my image to the new disk using CCC....worked really well and simple as....wish i had discovered that earlier...
    Thanks for your help

    kind regards
    Rossco
     

Share This Page