Turn keyboard backlight on in low light?

filmbuff

macrumors 6502a
Original poster
Jan 5, 2011
807
141
Since Mountain Lion (?) the preferences page only lists one option for keyboard backlighting which is "adjust keyboard brightness in low light". The problem is, this setting does the opposite of what it should. It assumes you want the backlight on all the time, and dims it to match the ambient lighting when the room goes dark.

Recently I've been using a pre-unibody MBP with Lion on it and have the keyboard set to illuminate in low light. This is a lot more useful and I like having the keyboard turn itself on when the lights go out. Is there a way to accomplish that in Mavericks? I tried the Lab-Tick app but that doesn't seen to do what I'm looking for.

And please don't suggest I install Lion on my 2012 MBA :D
 

flowrider

macrumors 603
Nov 23, 2012
5,566
1,977
I disagree, the setting does exactly what it should. The lighted keyboard turns itself off in lighted situations, when you don't need it, and illuminates when the room goes dark. The user has no control over the brightness level except to turn it on or off, or set it to turn it off after a specific time of non use. It's friendly to the way I want to use it.

If you want it lit all the time, just uncheck the brightness box.

Lou
 

filmbuff

macrumors 6502a
Original poster
Jan 5, 2011
807
141
I disagree, the setting does exactly what it should. The lighted keyboard turns itself off in lighted situations, when you don't need it, and illuminates when the room goes dark. The user has no control over the brightness level except to turn it on or off, or set it to turn it off after a specific time of non use. It's friendly to the way I want to use it.

If you want it lit all the time, just uncheck the brightness box.

Lou
Hm, you misunderstood. On my laptop if I check the "auto" box the keyboard will be on all the time and gets dimmer when the lights go out instead of brighter. Basically I want it to do exactly what you're saying but it does the opposite. Are you running Mavericks? I thought all Mavericks machines acted like mine, I could be wrong though.

and yes, I have tried an SMC reset.

----------

Actually nevermind, I just got it working haha. I had to turn the lights in the room off first, then adjust the keyboard backlight to the correct brightness, then enable automatic mode. Apparently if you do those steps with the lights on in the room you will get the opposite effect.
 

alphaod

macrumors Core
Feb 9, 2008
22,068
1,123
NYC
I just leave my backlight off at all times. I don't see the point of it. I never look at my keyboard.
 

flowrider

macrumors 603
Nov 23, 2012
5,566
1,977
^^^^Well, I guess that's you. Different strokes. I also have an illuminated Logitech KeyBoard on my Mac Pro. Wouldn't be without 'em.

Lou