Turn off +1 country code

Böhme417

macrumors 6502a
Original poster
Mar 11, 2009
602
654
I'm sure the right place to post this. I thought it was just something with my phone, but it is across all my devices - iPhone, iPad, and Mac. All incoming numbers show the +1 country code. Why??? I have dial assist turned off on my phone. I don't remember changing any setting. This started recently, and no one seems to have a decent explanation for it. I went to my carrier (Verizon), and they were clueless. Does anyone have any ideas how to get ride of it? I know it's not that big of a deal, but it just suddenly changed to being like that, and it's kind of annoying.
 

impaler

macrumors 6502
Feb 20, 2006
438
7
FL
I'm sure the right place to post this. I thought it was just something with my phone, but it is across all my devices - iPhone, iPad, and Mac. All incoming numbers show the +1 country code. Why??? I have dial assist turned off on my phone. I don't remember changing any setting. This started recently, and no one seems to have a decent explanation for it. I went to my carrier (Verizon), and they were clueless. Does anyone have any ideas how to get ride of it? I know it's not that big of a deal, but it just suddenly changed to being like that, and it's kind of annoying.
Don't think this belongs in the iCloud forum.
 

Böhme417

macrumors 6502a
Original poster
Mar 11, 2009
602
654
If someone could move it, that would be great...

It started with my phone and spread to my other devices, so I don't know where the thread belongs. My phone is iOS 8. My iPad is iOS 7. My Mac is running Mavericks.
 

theodas

macrumors newbie
Oct 8, 2014
1
0
Did you find a solution to this? I contacted Apple and they were clueless as well. Are we the only 2 on earth annoyed at this... I can t find a fix anywhere!

I'm sure the right place to post this. I thought it was just something with my phone, but it is across all my devices - iPhone, iPad, and Mac. All incoming numbers show the +1 country code. Why??? I have dial assist turned off on my phone. I don't remember changing any setting. This started recently, and no one seems to have a decent explanation for it. I went to my carrier (Verizon), and they were clueless. Does anyone have any ideas how to get ride of it? I know it's not that big of a deal, but it just suddenly changed to being like that, and it's kind of annoying.
 

Böhme417

macrumors 6502a
Original poster
Mar 11, 2009
602
654
Did you find a solution to this? I contacted Apple and they were clueless as well. Are we the only 2 on earth annoyed at this... I can t find a fix anywhere!
After about the 4th Apple rep, he told me that Verizon's Advanced Calling rollout is having glitchy implementation and that it's Verizon's issue. He had me change my LTE setting to data only and then reset my network settings. Once the phone restarted, calls of course now don't come through on LTE, but the caller ID is now correct (without the +1). I called Verizon back and talked to them about this. The rep stated there is nothing wrong on their end and they know nothing about such issues. Oh, well. I'll just suck it up and go back to LTE voice and data, as having VoLTE is worth this slight annoyance.

As an aside, Apple support is insanely better than Verizon. Every Apple rep spent time to listen to my issues and took multiple steps to help. They did everything they said they would and I got a follow-up call asking if I was satisfied. Verizon reps seemed very ill-equipped to help me and also seemed quick to get me off the phone. They repeated the same annoying script with every call. It was just a very generic, impersonal, and virtually useless experience.
 

MeDay

macrumors newbie
Jun 11, 2018
2
0
I'm sure the right place to post this. I thought it was just something with my phone, but it is across all my devices - iPhone, iPad, and Mac. All incoming numbers show the +1 country code. Why??? I have dial assist turned off on my phone. I don't remember changing any setting. This started recently, and no one seems to have a decent explanation for it. I went to my carrier (Verizon), and they were clueless. Does anyone have any ideas how to get ride of it? I know it's not that big of a deal, but it just suddenly changed to being like that, and it's kind of annoying.
(IT is foreign countries, using america's numbers through computers to try and scam anyone that will take the time to give them information. Everyday there is a new scam going on. I block them and they just get a new computer phone number and call again, I have over a 100 blocked calls, I wait to see if they leave a message and not one that has a +1 in front of the area code ever leaves a message, so I block them.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.