Turn off Auto-show sidebar in fullscreen Safari 9?

JFazYankees

macrumors 6502
Original poster
Feb 12, 2012
436
172
So in Safari 9, moving your cursor all the way to left edge of the screen while in fullscreen orientation causes the reading list/bookmarks/sharing bar to show then hide back away when the cursor is moved away from the edge. I HATE this with a passion, but I can't seem to find an option to turn it off for the life of me.
 

KALLT

macrumors 603
Sep 23, 2008
5,132
3,178
Report it to Apple. I currently seems to interfere with the left-side Dock anyway, so I suppose it still needs to be tweaked.
 

Pug72

macrumors 6502a
Mar 18, 2012
893
435
England
The way I fixed it was go into View on the tool bar and Show Bookmarks Sidebar. Then shut it and the auto one should be disabled.

Edit:

Worked for a while, now is back. :(
 
  • Like
Reactions: JacksonReynolds

SmOgER

macrumors 6502a
Jun 2, 2014
658
36
If you want to completely disable sidebar, you can hack it by editing com.apple.Safari.plist

First make sure that in Safari preferences "new tab open with" and "new windows open with" settings are set to anything other than Favorites, then change the SidebarViewModeIdentifier value from usual "Bookmarks" to let's say "B". This way cursor on the left in full screen will do nothing but don't try to manually show sidebar in view menu cause it will crash Safari and you will have to undo the changes before you can launch it again.

Very dirty hack, but hey it works if you really need it.

EDIT: Nevermind, turns out this doesn't work after all.
 
Last edited:

KALLT

macrumors 603
Sep 23, 2008
5,132
3,178
If you want to completely disable sidebar, you can hack it by editing com.apple.Safari.plist

First make sure that in Safari preferences "new tab open with" and "new windows open with" settings are set to anything other than Favorites, then change the SidebarViewModeIdentifier value from usual "Bookmarks" to let's say "B". This way cursor on the left in full screen will do nothing but don't try to manually show sidebar in view menu cause it will crash Safari and you will have to undo the changes before you can launch it again.

Very dirty hack, but hey it works if you really need it.

EDIT: Nevermind, turns out this doesn't work after all.
That option just defines the selected tab of the sidebar when you open it. When it’s set to “Bookmarks”, the bookmarks tab will be preselected. I also tried reducing the side of the sidebar to 0 (default is 240, which is also the minimum), but it can’t be tricked in that way either.
 

dogslobber

macrumors 68040
Oct 19, 2014
3,864
5,836
Apple Campus, Cupertino CA
Report it to Apple. I currently seems to interfere with the left-side Dock anyway, so I suppose it still needs to be tweaked.
I've been using the dock on the left to deal with this high priority bug Apple needs to fix. One issue is that if the mouse is a few pixels from the left then you get both the dock AND the stupid side bar!
 
  • Like
Reactions: dysamoria

elias3p

macrumors newbie
Oct 13, 2015
1
0
Just keep using Safari in fullscreen with the dock set to the left side in System Preferences. Enter this command in Terminal without quotes: "defaults write com.apple.Dock autohide-delay -float 1000 && killall Dock"

This will fix the issue.

Note: the dock will need the "Mission Control four finger swipe up" to show/hide it.

To make things back the way they were, enter this in Terminal: "defaults delete com.apple.Dock autohide-delay && killall Dock"
 

Krayzkat

Suspended
Apr 22, 2011
755
1,351
This really pisses me off. I'm fed up this popping up every time the mouse pointer accidentally touches the left edge of the screen (like when moving it out the way to watch a video).

The only way to disable it that i can find, also hides the bookmark tabs at the top of the screen. It seems pointless that Apple designed it this way. I'd rather have a slim 5mm high section of bookmark links at the top of my 27" screen, than have an annoying 50mm wide pop up of the same information.
 
  • Like
Reactions: dysamoria

weezerr

macrumors regular
Nov 7, 2006
189
91
This is driving me nuts. I use safari in full screen mode, and my dock on the left side of the screen with auto-hide turned on. When I mouse over to my dock, it pulls out the bookmark/reading list.

Is there really no way to turn this off?
 

Krayzkat

Suspended
Apr 22, 2011
755
1,351
This is driving me nuts. I use safari in full screen mode, and my dock on the left side of the screen with auto-hide turned on. When I mouse over to my dock, it pulls out the bookmark/reading list.

Is there really no way to turn this off?
I wish there was, it's really irritating to have my bookmarks pop out the left edge of the screen, while they are already shown at the top of the screen.....
 
  • Like
Reactions: dysamoria

weezerr

macrumors regular
Nov 7, 2006
189
91
I wish there was, it's really irritating to have my bookmarks pop out the left edge of the screen, while they are already shown at the top of the screen.....
There are complaint threads about this since 2015. How is there not a toggle yet??
 
  • Like
Reactions: dysamoria

dysamoria

macrumors 6502a
Dec 8, 2011
944
514
There are complaint threads about this since 2015. How is there not a toggle yet??
Because Apple don't listen to users. Apple live in a little mirror ball/echo-chamber.
[doublepost=1559855988][/doublepost]PS: I HATE the side-bar.
 

dysamoria

macrumors 6502a
Dec 8, 2011
944
514
They FINALLY turned this off at some point. I'm sitting here with my girlfriend's new MacBook Pro 13" with Catalina and it FINALLY doesn't have this annoying as hell autopopup sidebar!!
 

btom6989

macrumors newbie
Jul 19, 2020
1
0
They FINALLY turned this off at some point. I'm sitting here with my girlfriend's new MacBook Pro 13" with Catalina and it FINALLY doesn't have this annoying as hell autopopup sidebar!!
I'm sitting here with the same laptop and it is still appearing and I can't work out how to turn it off!! very annoying! 😤
 

Zach Jackson

macrumors newbie
Apr 21, 2017
2
0
I am stunned that this has been reported for the last five years (or more) and yet Apple hasn't done anything about this, in the MANY software updates they have released. Why not just make this an option? Why force us to have it, if so many clearly don't want it??? Very odd. Seems like they would specifically care about customer feedback, since we are, after all, the one's keeping them in business. Guess they arrogantly believe we will simply keep using their products no matter what they do or fail to do!

BTW, don't recall this showing up, until I upgraded to Catalina. So maybe I have been dodging this bullet for years! But no more. Time to switch browsers!
 

dysamoria

macrumors 6502a
Dec 8, 2011
944
514
I'm sitting here with the same laptop and it is still appearing and I can't work out how to turn it off!! very annoying! 😤
Huh. That’s really bizarre. 😕 It was a surprise to me that it wasn’t popping up on my girlfriend’s Safari. I’ll have to try to look to see if it’s a setting that is now correctly obeying user settings now or if it’s just a bug I encountered where it stopped popping up at the time.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.