turn off FileVault with Terminal

Discussion in 'macOS High Sierra (10.13)' started by johnbclark, Mar 22, 2018.

  1. johnbclark macrumors newbie

    Joined:
    Mar 19, 2010
    #1
    How to turn off FileVault with Terminal.
    sudo fdesetup disable

    returns a message "command not found"

    any suggestions would be appreciated...
    MacBook Pro 2012
    Mac OS High Sierra installed, unfortunately FileVault was turned on during the install
    The machine has been running for 3 days..
    760 GB HD with 700GB free space...

    have tried:
    disconnecting Internet
    reboot in Recovery
    ran Disk First Aid on HD
     
  2. DeltaMac macrumors G3

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #2
    60GB used? Can you just give up and erase the drive, then reinstall macOS?
    I guess my real question is: do you have a backup of your drive, so you could simply start over with a fresh install, then restore your files and apps?
     
  3. Shadow Jolteon macrumors regular

    Shadow Jolteon

    Joined:
    Feb 1, 2018
    Location:
    United States
    #3
    That is strange that it isn't finding fdesetup. You may want to try running this instead:
    Code:
    sudo /usr/bin/fdesetup disable
     
  4. johnbclark thread starter macrumors newbie

    Joined:
    Mar 19, 2010
  5. treekram macrumors 68000

    Joined:
    Nov 9, 2015
    Location:
    Honolulu HI
    #5
    If you're doing this from the Terminal while running Recovery, you don't need "sudo". I think the same would apply from single-user mode.

    If you're not in Recovery or single-user mode, in Terminal, you can type "which fdesetup" and it should tell you the path of the command. If some how "/usr/bin" isn't in the path you can try "sudo /usr/bin/fdesetup" (or whatever the full path is).
     
  6. DeltaMac macrumors G3

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #6
    I am curious if johnbclark is actually booting to Internet Recovery. Some terminal commands are not available when booted to internet recovery.

    @johnbclark: Internet Recovery boots up showing a spinning globe, and not the usual Apple icon.
     
  7. BLUEDOG314 macrumors 6502

    BLUEDOG314

    Joined:
    Dec 12, 2015
    #7
    Never heard of the method that was suggested above, but I have my own way that I've used before. Given model and size of drive I am going to assume this is a mechanical drive and not an SSD. Also assuming the drive is fully encrypted and not still in the process, go to recovery, then terminal and first do 'diskutil cs list' and get the UUID for the encrypted Macintosh HD volume and copy it. Then do 'diskutil cs unlockvolume PasteUUID' hit enter and put in the password. Then do 'diskutil cs decryptvolume PasteUUID' hit enter and put in password.

    I of course do agree with the idea of just backing up the data, nuking the drive and restoring backup as a better and faster solution.
     
  8. Nonamegary macrumors newbie

    Nonamegary

    Joined:
    Apr 29, 2018
    #8
    That code worked for me but I started with ,status first and it says 87.22, so I’ll let it go and check it again after work
     
  9. Allendrexel macrumors newbie

    Allendrexel

    Joined:
    Dec 15, 2018
    #9

    I am glad I saw this, it worked for me.
     
  10. vocals07 macrumors newbie

    vocals07

    Joined:
    Feb 10, 2019
    Location:
    Hampton GA
    #10
    I am getting this
    FileVault was not disabled (-69573
     
  11. vocals07 macrumors newbie

    vocals07

    Joined:
    Feb 10, 2019
    Location:
    Hampton GA
    #11
    I tried this and it keeps saying FileVault not disabled
     
  12. Shadow Jolteon macrumors regular

    Shadow Jolteon

    Joined:
    Feb 1, 2018
    Location:
    United States
    #12
    Try running the following and see what it shows:
    Code:
    sudo /usr/bin/fdesetup status -extended -verbose
     

Share This Page