Turn off FTP server

Discussion in 'OS X Mavericks (10.9)' started by gstevie, Jul 28, 2013.

  1. gstevie macrumors 6502

    gstevie

    Joined:
    Jul 12, 2009
    Location:
    Glasgow
    #1
    Hey guys having a bit of a brick wall situation here. I turned on the FTP server on Mavericks using terminal command "sudo -s launchctl load -w /System/Library/LaunchDaemons/ftp.plist" that worked but now I am trying to turn it off using command "sudo -s launchctl unload -w /System/Library/LaunchDaemons/ftp.plist" problem I am having is once I typed that into terminal is comes up saying "launchctl: Error unloading: com.apple.ftpd"

    And will not turn off, any ideas whats going on and how to get it off?
    Thanks
     
  2. SanjeevRana macrumors 6502a

    SanjeevRana

    Joined:
    Aug 2, 2011
    #2
    You need to stop the service first using :

    sudo launchctl stop com.apple.ftpd

    then unload
     
  3. LekeFly macrumors newbie

    Joined:
    Apr 25, 2007
    #3
    Code:
    mac:~ macbook$ sudo launchctl stop com.apple.ftpd
    launchctl stop error: No such process
    mac:~ macbook$ sudo -s launchctl unload -w /System/Library/LaunchDaemons/ftp.plist
    launchctl: Error unloading: com.apple.ftpd
    
    Started a FTP service, now i can't shut it down.. help :(
     

Share This Page