Turn Off Game Notifications?

Discussion in 'iPhone' started by w00t951, Jan 31, 2012.

  1. w00t951 macrumors 68000

    w00t951

    Joined:
    Jan 6, 2009
    Location:
    Pittsburgh, PA
    #1
    Wirelessly posted (Mozilla/5.0 (iPhone; CPU iPhone OS 5_0_1 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A406 Safari/7534.48.3)

    Certain games (especially Fruit Ninja) like to post badges on my Home Screen about promotions that I couldn't care less about. How can I disable these annoyances? The games don't show up in Notification Center. Thanks.
     
  2. Daveoc64 macrumors 601

    Joined:
    Jan 16, 2008
    Location:
    Bristol, UK
    #2
    That's odd.

    Fruit Ninja doesn't appear in my Notification Center and it doesn't add a badge to its icon.

    Do you have the latest version of it installed?

    EDIT: Spoke too soon!

    It added a badge to the icon just after I closed it.

    Seems very odd that it can do that.

    I can't think of a way to disable it. There's nothing in-App, it doesn't add anything to the Settings menu and it doesn't appear under the notifications menu.
     
  3. pilot1226 macrumors 6502a

    pilot1226

    Joined:
    Mar 18, 2010
    Location:
    USA
    #3
    Wirelessly posted (Mozilla/5.0 (iPhone; CPU iPhone OS 5_0_1 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A406 Safari/7534.48.3)

    You can surely disable GameCenter as a whole though. Go for that.
     
  4. Daveoc64 macrumors 601

    Joined:
    Jan 16, 2008
    Location:
    Bristol, UK
    #4
    It's not related to Game Center.
     
  5. w00t951 thread starter macrumors 68000

    w00t951

    Joined:
    Jan 6, 2009
    Location:
    Pittsburgh, PA
    #5
    It's just a little "1" or "2" that hovers over the game icon. It's generally news from Halfbrick Studios (the game dev) about some game sale. It has nothing to do with Game Center.
     
  6. pilot1226 macrumors 6502a

    pilot1226

    Joined:
    Mar 18, 2010
    Location:
    USA
    #6
    Oh. If it's just the icon itself, you can clear that out by hitting the "news" button inside the game. Once you view it, it should go away. At least, it did for me.
     
  7. w00t951 thread starter macrumors 68000

    w00t951

    Joined:
    Jan 6, 2009
    Location:
    Pittsburgh, PA
    #7
    I know that it goes away if you view the "news". However, I prefer not to have to do such trivial things.
     
  8. pilot1226 macrumors 6502a

    pilot1226

    Joined:
    Mar 18, 2010
    Location:
    USA
    #8
    I suggest you e-mail/contact the developer. If they hear enough of that from their user base, they'll code it in. If they hear nothing, why change?
     
  9. Tea-Aholic macrumors 6502

    Joined:
    Dec 8, 2011
    Location:
    Melbourne, Australia
    #9
    Can't you just go to Settings > Notifications > Fruit Ninja and turn off badges?
     
  10. pilot1226 macrumors 6502a

    pilot1226

    Joined:
    Mar 18, 2010
    Location:
    USA
    #10
    I don't have an option for this on my screen. Though, I have Game Center notifications completely disabled.
     
  11. Daveoc64 macrumors 601

    Joined:
    Jan 16, 2008
    Location:
    Bristol, UK
    #11
    It doesn't appear in that menu because it doesn't use Push or Local Notifications.
     
  12. Tea-Aholic macrumors 6502

    Joined:
    Dec 8, 2011
    Location:
    Melbourne, Australia
    #12
    Yes, my apologies, I didn't notice that.
     

Share This Page