Turn off music in notification centre

Christoffee

macrumors 6502
Original poster
Jul 26, 2012
365
496
UK
Hello everyone

Is there a way to turn off the music widget in the notification centre?

This is not just cosmetic, it is a real annoyance to me. If my phone is in my pocket and I get a notification the screen lights up, music is there, my leg will skip a track. This is annoying for music, but when listening to an audiobook with hour long tracks this is very annoying indeed. I have turned off raise to wake which has cut the problem down to notifications.

From research it seems the answer is no. But I wondered if anyone else has an idea.

Thank you
 

C DM

macrumors Sandy Bridge
Oct 17, 2011
49,618
18,161
Doesn't seem like there's a way. The one other thing that you can try, which affects somewhat more than just this, but you can use DND while you are listening to something so that notifications don't turn on your screen. That said, I was under the impression that the recent phone models supported a feature where the phone screen wouldn't turn on for notifications if it was covered by something (like being in a pocket or in a purse), unless it was only in relation to when the phone was actually specifically placed upside down on its screen.
 
  • Like
Reactions: Christoffee

Christoffee

macrumors 6502
Original poster
Jul 26, 2012
365
496
UK
Doesn't seem like there's a way. The one other thing that you can try, which affects somewhat more than just this, but you can use DND while you are listening to something so that notifications don't turn on your screen. That said, I was under the impression that the recent phone models supported a feature where the phone screen wouldn't turn on for notifications if it was covered by something (like being in a pocket or in a purse), unless it was only in relation to when the phone was actually specifically placed upside down on its screen.
DND is a good idea! The simple solutions are the best!

I thought I was going to have to get a flappy phone case!

As for not turning the screen on when could covered, this certainly doesn’t seem to be the case. I regularly lock myself out of my phone as my leg gets my passcode wrong.
 

NoBoMac

Moderator
Staff member
Jul 1, 2014
2,881
1,209
Another tweak is to turn off lock screen Notifications. Should "silence" the lock screen other than phone calls.

Other than getting rid of the skinny jeans, that's about all that could be done.
 
  • Like
Reactions: Christoffee

Cayden

macrumors 6502a
Jul 10, 2014
794
386
Utah
From previous posts I’d assume your phone is in your pocket with the screen facing your leg. An easy fix would be simply having the screen face out in our pocket instead of in, that way your leg can’t initiate any accidental touches
 

Christoffee

macrumors 6502
Original poster
Jul 26, 2012
365
496
UK
From previous posts I’d assume your phone is in your pocket with the screen facing your leg. An easy fix would be simply having the screen face out in our pocket instead of in, that way your leg can’t initiate any accidental touches
Yeah, I know. “I’m pocketing wrong.” :)
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.