Turn Off Twitter Following Favorites/Retweets

RichardC300

macrumors 65816
Original poster
Sep 27, 2012
1,231
96
Chapel Hill, NC
Recently, I've been getting daily notifications of people, who I am following on Twitter, favoriting and retweeting other people that I follow. I've turned this off in a previous version of Twitter (on iOS 7), but ever since iOS 8 and maybe a Twitter update, it has turned back on, and I can't find the option to turn it off again. Has anybody found a solution other than completely turning off Twitter notifications? It's extremely annoying.
 

SamAshleyBlogs

macrumors regular
Jul 11, 2010
102
4
Columbus, Ohio
Recently, I've been getting daily notifications of people, who I am following on Twitter, favoriting and retweeting other people that I follow. I've turned this off in a previous version of Twitter (on iOS 7), but ever since iOS 8 and maybe a Twitter update, it has turned back on, and I can't find the option to turn it off again. Has anybody found a solution other than completely turning off Twitter notifications? It's extremely annoying.
I've turned it off. Multiple times. On my iPhone app and web version. They keep toggling back on. Can't figure it out either but it's absolutely killing me.

----------

I've turned it off. Multiple times. On my iPhone app and web version. They keep toggling back on. Can't figure it out either but it's absolutely killing me.
Ok, take it back. Just tried something new. I SWEAR this wasn't there before, but in the Notifications section on the app the first thing listed now is "Tweets". Mine had 6 people arbitrarily chosen. Those were the people I kept getting notifications from. See if that helps?
 

RichardC300

macrumors 65816
Original poster
Sep 27, 2012
1,231
96
Chapel Hill, NC
I've turned it off. Multiple times. On my iPhone app and web version. They keep toggling back on. Can't figure it out either but it's absolutely killing me.

----------



Ok, take it back. Just tried something new. I SWEAR this wasn't there before, but in the Notifications section on the app the first thing listed now is "Tweets". Mine had 6 people arbitrarily chosen. Those were the people I kept getting notifications from. See if that helps?
I didn't have any people under "Tweets", but I may have found the answer, because I haven't been getting any undesired notifications for the past couple of days. On the same page as "Tweets", I toggled off "New contacts", "Recommendations" (may be the target issue), "News", and "Twitter Alerts". Also turned off "Other", but I have no idea what that may be. Must have missed these as I was going through the settings before making this thread.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.