"Turn on home sharing"... getting sick and tired

Discussion in 'Apple TV and Home Theater' started by Brien, Jan 16, 2016.

  1. Brien macrumors 68020

    Brien

    Joined:
    Aug 11, 2008
    #1
    First of all, I should add I have a Time Capsule and an otherwise all-Apple household.

    But for whatever reason, every. single. time. I use the remote app I have to go on my Apple TV (or iTunes library) and re-enable home sharing. It NEVER sticks.

    Any help would be appreciated.
     
  2. myrtledog macrumors member

    Joined:
    Aug 15, 2015
    #2
    Lol! I've wondered about this as well. Thought it was just me.
     
  3. WigWag Workshop macrumors 6502

    WigWag Workshop

    Joined:
    Feb 3, 2011
    Location:
    Central Ohio (Born and Raised in SE WI)
    #3
    Odd, I don't have this issue. My iTunes library is stored on a iMac, and we use home sharing all the time.
     
  4. Alrescha macrumors 68020

    Joined:
    Jan 1, 2008
    #4
    Same. I turned on Home Sharing on my Mac years ago and have not had to touch it since. Once in a great while, after a major iOS upgrade, I might have to sign back into Home Sharing on my iPhone or iPad. It is usually so long between intervals that I have to check my Mac to remind myself which AppleID I am using...

    A.
     
  5. benjitek macrumors 6502a

    benjitek

    Joined:
    Sep 23, 2012
    #5
    Doesn't happen to me with a MacBook Pro, Verizon FiOS Quantum Gateway router and the Remote app running on my iPhone 6S Plus or iPhone 6S. The only thing I've noticed is my iPhones feel hot to the touch with the Remote app running more than 10 minutes or so...
     
  6. 2010mini macrumors 68040

    Joined:
    Jun 19, 2013
    #6
    If my mini has been sleeping for extended periods, homeSharing doesn't work. But once woken it connects fine

    I am using 2 Verizon Fios N routers.

    But HomeSharing has been bad for years now. Apple needs to overhaul iTunes badly
     
  7. Spankey macrumors 6502a

    Joined:
    Sep 30, 2007
    Location:
    NJ
    #7
    Kinda why I moved to Plex. I never use the computer icon again.
     
  8. matrix07 macrumors 68040

    matrix07

    Joined:
    Jun 24, 2010
    #8
    Neither do I. 2012 Mac mini (Mavericks) + latest gen Time Capsule.
     
  9. kagharaht macrumors 6502a

    Joined:
    Oct 7, 2007
    #9
    Leave the machines running and never turn it off or sleep. Apple TV and Home Sharing is happy as long as you keep it running and wasting power 24/7. It loves to stay in and waste energy.
     
  10. McScooby macrumors 6502

    Joined:
    Oct 15, 2005
    Location:
    The Paps of Glenn Close, Scotland.
    #10
    Had it once after last :apple:TV update, shut iTunes never mind about turning home sharing on/off, opened back up, rock solid since even with MBP & :apple:TV being turned off each night.
     
  11. antonypg macrumors member

    Joined:
    May 8, 2008
    #11
    I had this problem constantly when I had set my Apple TV 4 to a fixed IP, it never worked after a period of sleep, but when I switched it back to automatic DHCP the problem went away. I like to give devices fixed IP addresses, but I am not sure if sometimes it just causes more grief.

    I have also noticed a lot less problems since I switched from my old Belkin router to an Airport Extreme.
     
  12. GLS macrumors 6502

    Joined:
    Jun 26, 2010
    #12
    Here's our setup at home:

    -Macmini is hosting iTunes. Library is on a NAS drive. Static IP on Macmini. Wired network connection

    -5 Apple TV's in house (2 gen 2, 2 gen 3, 1 gen 4). All using wifi, all using dhcp provided addresses.

    Here's the drill I had to use in order to get away from the "turn on home sharing" message:

    -On Macmini, set it to never sleep.

    -Then, prepared an applescript to shut itunes down on the macmini once per day and then immediately restart itunes. I set the script up to run at 5 am.

    Once I did that, I've never seen a turn on message on any of the Apple TV's.
     
  13. The Mad Hatter macrumors 6502a

    The Mad Hatter

    Joined:
    Oct 12, 2004
    Location:
    SoCal
    #13
    The word in bold is why. Ever since I updated my Mini/server to Yosemite from Mavericks, I have to CONSTANTLY send a WOL signal from my phone to wake it up. Before, my ATV would wake it up no prob.
     
  14. Agent2015 macrumors regular

    Agent2015

    Joined:
    Oct 17, 2015
    Location:
    Sonoran Desert
    #14
    My 2012 Mac mini has been running El Capitan (just updated to 10.11.3) since EC was released and have no issues whatsoever with Home Sharing to the ATV4 or any other iPhone or iPad in the house. As others have pointed out, the Mac mini is set to never sleep.
     
  15. The Mad Hatter macrumors 6502a

    The Mad Hatter

    Joined:
    Oct 12, 2004
    Location:
    SoCal
    #15
    Yes, if I set my Mini to never sleep, I wouldn't have a problem. However, the way it's "supposed" to work (or at least it did in the past) is to sleep while idle, and wake up when needed. Now (since I switched it to Yosemite) anytime I want to access my sleeping Mini (ie. to stream, access files, etc.), I have to send a Wake-On-LAN signal to it to wake it up. Heck, it doesn't even show as being connected on my MBPr or Mac Pro until I wake it up.

    I wish I knew if El Captain fixes this. If so, I'd update in a heartbeat. However, right now, I'm already looking at downgrading a full OS X level (Yosemite -> Mavericks). If I try out El Capitain, and it doesn't work, I'll have to go back 2 levels. I don't know if my setting and backups (or my psyche) can handle the strain. ;-)
     
  16. matrix07 macrumors 68040

    matrix07

    Joined:
    Jun 24, 2010
    #16
    Mine set to sleep after 15 minutes (both computer and display) and "Wake for network access" is checked.
     
  17. Snoopy4 macrumors 6502a

    Snoopy4

    Joined:
    Dec 29, 2014
    #17
    It seems like we get this every time there is an update. Its like it does a library reset or something.
     
  18. Brien thread starter macrumors 68020

    Brien

    Joined:
    Aug 11, 2008
    #18
    Then is there a way to keep the Apple TV from updating? I am getting fed up and "turn it off and back on" is NOT a valid response.

    I have an all-Apple household, this stuff should 'just work'.
     
  19. Boyd01 macrumors 68040

    Boyd01

    Joined:
    Feb 21, 2012
    Location:
    New Jersey Pine Barrens
    #19
    I have a 2TB Time Capsule, two ATV3's, a 2013 MBA, iPhone 6s+ and a 2012 Mini on Mavericks that runs 24/7 as an iTunes server. Never had any problems and can't think of any reason why I should upgrade the software on the Mini, since it only runs iTunes and "just works".

    Funny, I've had the new iPhone for 2 months and don't think I've ever run the remote app on it until just now. It found all my devices immediately.

    The applescript to restart iTunes is interesting. I find that a variety strange things can start happening after a month or two of 24/7 uptime on the Mini. I just do a restart when that happens and everything is fine.
     
  20. pjarvi macrumors 65816

    pjarvi

    Joined:
    Jan 11, 2006
    Location:
    Round Lake, IL
    #20
    All my HomeSharing problems were resolved by restarting Apple's Bonjour service. To do so on a Mac:

    1.) Close iTunes
    2.) Open Terminal
    3.) In Terminal run this command: sudo killall -HUP mDNSResponder
    4.) Reboot

    Source: https://support.apple.com/en-us/HT202516

    You should also consider configuring your router to assign each device a reserved IP address.
     
  21. The Mad Hatter macrumors 6502a

    The Mad Hatter

    Joined:
    Oct 12, 2004
    Location:
    SoCal
    #21
    Thank you, thank you <Gives Big Virtual-Hug> ...

    You may have <knock on wood> solved my "ATV4 not waking up my Mini-server" problem.

    ... and again ... Thank you!
     
  22. RadioGaGa1984 Suspended

    RadioGaGa1984

    Joined:
    May 23, 2015
    #22

    Funny, mine sleeps all the time and I don't have this issue.
     
  23. kagharaht macrumors 6502a

    Joined:
    Oct 7, 2007
    #23
    Wakes up automatically when ATV or iOS devices access the home shared media right?
     

Share This Page