Turning off the automatic graphics card switching

Discussion in 'MacBook Pro' started by jsm68, Feb 24, 2014.

  1. jsm68 macrumors newbie

    Joined:
    Feb 24, 2014
    #1
    Hi,

    I would appreciate help with the following. My cursor on my MacBook Pro (with retina, early 2013 version) freezes when I use Safari, and I found the following solution at the Apple site forum:

    1. turn off the automatic graphics card switching
    2. turn off automatic display brightness

    I was able to turn off the automatic display brightness, but can't figure out how to turn off the automatic graphics card switching... All the web searches for this suggest that under System Preferences/ Energy Saver there should be a button/switch where you can turn off the graphics card. However, on my computer there's no such switch in the Energy Saver preferences panel. Is there any other place other than System Preferences where the graphics card can be switched off?

    Thank you,
    Julie
     
  2. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #2
    Did you try gfxCardStatus I'm not sure it does exactly what you're looking for, but take a look.
     
  3. yjchua95 macrumors 604

    Joined:
    Apr 23, 2011
    Location:
    GVA, KUL, MEL (current), ZQN
    #3
    In System Preferences, under Energy Saver, you can check the option to only use high performance graphics.

    And of course, that eats into your battery life.

    Go download GFXcardstatus and force the rMBP into Iris-only on battery.
     
  4. priitv8 macrumors 68020

    Joined:
    Jan 13, 2011
    Location:
    Estonia
    #4
    gfxCardStatus is the only really working way to force iGPU or dGPU at will. The only trouble with this is, that the setting doesn't survive reboots, so you need to make the switch manually every time after fresh boot.
     
  5. snaky69 macrumors 603

    Joined:
    Mar 14, 2008
    #5
    If you have a 13 inch or low end 15 inch, you do not have automatic graphics card switching as you do not have 2 graphics card. Since you omitted to mention what model you actually have, one can only assume this could be your problem.
     
  6. jsm68 thread starter macrumors newbie

    Joined:
    Feb 24, 2014
    #6
    Hi - Thanks for the reply. (And thank you everyone who replied to my post) Yes, I have a 13 inch rMBPro, early 2013 model. So that means I don't have 2 graphics card, it seems... This would explain why there is no option for graphic card switching under Energy Saver on this computer.

    I have turned off the automatic display brightness a couple of days ago and there's been no more freezing of my cursor since then (was only freezing when I was using Safari). Hopefully this solved the problem until Apple releases a fix through a Mavericks update...

    Julie
     

Share This Page