TV + 1TB HD = Issues

Discussion in 'Apple TV and Home Theater' started by tabosco23, Jul 21, 2009.

  1. tabosco23 macrumors newbie

    Jul 21, 2009
    Well I've been trying to get my 1TB WD SATA drive hooked up to my AppleTV for a few days now and I'm running into random issues. In case it matters, I'm running OS 10.5.7 and the most recent AppleTV software (not sure what it is these days).

    I've been successful connecting the HD to the AppleTV via random cables and converters and everything seemed to be running fine using these instructions. That is until I tried to Factory Reset the unit and I got an error message saying the AppleTV couldn't reset. Also, the free space on the 1TB HD was not being seen, but rather the 149GB I had originally started with. It seems like a partitioning issue but I don't know enough about HDs to know what's going on.

    I tried erasing and installing a few other times to no avail. Now I'm having issues with the initial formatting of the HD and can't seem to get through the first few steps of installing the disk images onto the new HD. During the original setup I ran into the error message "newfs_hfs: /dev/rdisk1s4: partition size not a multiple of 4k."

    Has anyone been successful connecting a SATA drive to the AppleTV? If so, I could sure use some help. The most overwhelming questions I'm running into seem to be:

    1) What format does the 1TB HD need to be in to get things going?
    2) Which is the better method ... creating a full disk image of the AppleTV or creating the EFI.dmg and Recovery.dmg files?
    3) Any idea what the situation is with the "newfs_hfs: /dev/rdisk1s4: partition size not a multiple of 4k" error?
    4) Why do I keep running into issues with the factory recovery?

    Thanks in advance for your help and suggestions. Unfortunately I don't know much about the inner workings of what's going on, but have been following what I've found on these forums.
  2. dynaflash macrumors 68020

    Mar 27, 2003
    I start with a single partition in hfs+

    I copy the efi, recovery and boot images. Awkward or some site has intructions to just copy the efi and recovery images and let a factory restore create the boot partition ... I never liked it and had issues with it. Just as easy to copy the boot partition while doing the other two. Then it's set to go when you fire it up.

    Nope, did you start with a single fresh hfs+ partition first ? Its very hard to say unless the exact steps you followed were known.
    Because you're drive is not properly prepared.

    Cloning the drive can be the much harder part of doing this upgrade. It's almost as if someone should write a gui utility for just this purpose.
  3. tabosco23 thread starter macrumors newbie

    Jul 21, 2009
    Thanks for the follow up, I do appreciate it. I had not been making an image of the boot so that maybe part of the issue. Regarding the HD formatting, is it best to do that in Disk Utility or through Terminal itself?

    I'll give it another shot and we'll see how it goes. Thanks again!
  4. tabosco23 thread starter macrumors newbie

    Jul 21, 2009
    I went through the steps this time creating images for EFI, Recovery, and Boot and still can't seem to get this thing working. I think the issue lies with this line (my typing in bold):

    Brads-PowerBook:~ bgalland$ newfs_hfs -J -v Media /dev/disk1s4
    newfs_hfs: /dev/rdisk1s4: partition size not a multiple of 4K.

    Everything else seems to be identical to the instructions found here.

    I used Terminal to reformat the drive originally (here are the commands from Terminal):

    Brads-PowerBook:~ bgalland$ diskutil eraseDisk HFS+ ATV disk1
    Started erase on disk disk1
    Creating partition map
    Formatting disk1s3 as Mac OS Extended with name ATV
    [ + 0%..10%..20%..30%..40%..50%..60%..70%..80%..90%..100% ]
    Finished erase on disk disk1
    Finished partitioning on disk disk1

    To verify the erase, I used the "diskutil list" function (see below):

    Brads-PowerBook:~ bgalland$ diskutil list
    0: Apple_partition_scheme *55.9 Gi disk0
    1: Apple_partition_map 31.5 Ki disk0s1
    2: Apple_HFS Macintosh HD 55.8 Gi disk0s3
    0: Apple_partition_scheme *931.5 Gi disk1
    1: Apple_partition_map 31.5 Ki disk1s1
    2: Apple_HFS ATV 931.4 Gi disk1s3


Share This Page