TvOS 11.3 Final ycbcr is broken

Discussion in 'Apple TV and Home Theater' started by mrrobotoplus, Mar 29, 2018.

  1. mrrobotoplus macrumors member

    Joined:
    Jul 23, 2010
    #1
    Made measurements on my ATV 4K with final release 11.3 and to me it seems that ycbcr is broken, grayscale is all wrong. I get correct readings only with RGB High.
    Ted patterns with internal player and Amazon Firestick + Mobile forge are working great.

    Equipment: LG B7V, i1Display, Calman Enthusiast.
     
  2. thatJohann macrumors 65816

    thatJohann

    Joined:
    Jul 5, 2013
    Location:
    NYC
  3. priitv8 macrumors 68040

    Joined:
    Jan 13, 2011
    Location:
    Estonia
    #3
    Since my 11.3 update I noticed tvOS defaulted to 4K Dolby Vision 60Hz and YCbCr 4:4:4 output (I had it set on 4:2:0 before update). Could that be a reason?
     
  4. geesus macrumors 6502

    geesus

    Joined:
    Jul 3, 2015
    #4
    ycbcr is definitely crushing shadow detail on my LG B6 too. It's been a constant issue throughout the beta for the latest firmware so I'm not surprised it has made it into the final release.
     
  5. mrrobotoplus, Apr 9, 2018
    Last edited: Apr 9, 2018

    mrrobotoplus thread starter macrumors member

    Joined:
    Jul 23, 2010
    #5
    The RGB is not accurate in YCbCr. Look at my screenshots:

    - Native USB player with Ted's Patterns and Amazon Firestick + Mobile Forge are correct.
    - ATV RGB High is correct
    - ATV YCbCR is not accurate

    Measurements made with x-rite iDisplay pro and Calman on my LG Oled B7.
    --- Post Merged, Apr 9, 2018 ---
    If you have match DR and FR to ON atv switches also the chroma settings.
    --- Post Merged, Apr 9, 2018 ---
    Yes, check gamma in my screenshots. you can see clearly that ycbcr has 5ire darker compared to the other 2. this means crushed blacks in a not calibrated tv.
     

    Attached Files:

  6. geesus macrumors 6502

    geesus

    Joined:
    Jul 3, 2015
  7. mrrobotoplus thread starter macrumors member

    Joined:
    Jul 23, 2010
    #7
    The Infuse team reported the bug to Apple. Finger crossed.
     
  8. Hoosier317, Apr 10, 2018
    Last edited: Apr 10, 2018

    Hoosier317 macrumors 6502a

    Hoosier317

    Joined:
    Sep 21, 2016
    #8
    Have you retested with the current beta?

    Also, James @ Infuse seems to be saying that this bug only impacts HDR > SDR conversions.
     
  9. mrrobotoplus thread starter macrumors member

    Joined:
    Jul 23, 2010
    #9
    No, ycbcr is a global setting and I always tested in Sdr only. James is thinking only about HDR and to make infuse a Plex client.

    No tests in new beta. I’m gonna wait the final tvOS bug free and infuse as it should be (I use the atv also for my HomeKit environment, I need to stay on stable releases) For now I’m enjoying the LG native apps which are bit perfect. BTW today Netflix updated its app and it’s ok with the crush black.
     
  10. Hoosier317 macrumors 6502a

    Hoosier317

    Joined:
    Sep 21, 2016
    #10
    You seem to be the only person reporting this issue.
     
  11. mrrobotoplus, Apr 11, 2018
    Last edited: Apr 11, 2018

    mrrobotoplus thread starter macrumors member

    Joined:
    Jul 23, 2010
    #11
    do you have a meter to prove i am wrong? post your tests so we have something to talk about.
    i opened a thread at the infuse forum, james asked me for more infos and i posted the same screenshots above. He never replied. He did in another thread saying he is aware about all this 11.3 bugs (HDR and SDR) and he reported everything to Apple.
     
  12. Hoosier317 macrumors 6502a

    Hoosier317

    Joined:
    Sep 21, 2016
    #12
    I didn’t say you are wrong. I said you appear to be the only person reporting this. I have the same meter you have, but mine needs to be profiled and my Chromapure license has lapsed. James has said that, as far as he knows, this is only impacting HDR to SDR conversions. I’ve seen your thread there.

    I would suggest posting your findings in the Apple TV thread over at AVS. You’re more likely to bump into people with proper meters and software there.
     
  13. mrrobotoplus, Apr 11, 2018
    Last edited: Apr 12, 2018

    mrrobotoplus thread starter macrumors member

    Joined:
    Jul 23, 2010
    #13
    Even if your meter is not profiled you can check for discrepancies between your HDMI ports. Give it a try.

    I’ve posted already in the Avs forum but the ATV section is not crowded of calibrators like the calibration section. Also, at this time they are all busy reviewing the 2018 sets delivered in the last days.

    James is quite vague on this topic. He may just say that he can’t replicate my findings instead of not answering. But Trust me, 11.3 bugs aside, infuse new metal player is out of reference as hell. The old player they were using was bit perfect and is the one flatpanelshd.com used for their first ATV 4K review.
     
  14. geesus macrumors 6502

    geesus

    Joined:
    Jul 3, 2015
    #14
    I have it too. Having to use RGB for now.
     

Share This Page