tvOS 12.3 and AppleTV 4K Kicking Me Out of Apple Purchased TV Shows

Discussion in 'Apple TV and Home Theater' started by JoelBC, May 18, 2019.

  1. JoelBC macrumors 6502a

    Joined:
    Jun 16, 2012
    #1
    Apologies for the long title.

    I have an AppleTV 4K. I recently upgraded the software to tvOS 12.3.

    The problem that I am now experiencing -- which did not exist prior to the tvOS upgrade -- is that when I watch an episode of a TV Series that I purchased from Apple I am being kicked out (i.e. back to the AppleTV 4K Home Screen) after a few minutes of watching. This problem occurs:

    1. When I start watching an episode at any point during the episode (i.e. start of the episode or any other episode point in time) ; and

    2. On all 3 AppleTV 4Ks that I own.

    Worth also noting is that this problem only occurs with Apple purchased content (i.e. this problem does not occur with NetFlix, Amazon Prime, etc.)

    Would like to know if anyone else is experiencing this problem and, if yes, what is the fix / workaround.

    Thx!
     
  2. Soondae macrumors member

    Soondae

    Joined:
    May 22, 2012
    Location:
    Hua Hin, Thailand
    #2
    WOW this is errily similar to the issue many us are having with the MLB at Bat APP. I haven't tried any of my purchased content since the upgrade. Actually I only have a couple of music videos purchased from Apple but will try later today and report back. The issue crashing to home screen for us MLB users was occurring prior to the TVOS 12.3 upgrade BTW. Also I have the ATV4K.
     
  3. JoelBC thread starter macrumors 6502a

    Joined:
    Jun 16, 2012
    #3
    Excellent and much appreciated as I really would like to get to the bottom of this..

    Thanks!
     
  4. Soondae macrumors member

    Soondae

    Joined:
    May 22, 2012
    Location:
    Hua Hin, Thailand
    #4
    Well I don't think I am of much help for your issue. Since all I have is some purchased Music videos and that they play from the music APP, I don't have any purchased movies or TV shows. My Music videos play just fine in TVOS 12.3
     
  5. Audit13 macrumors 601

    Audit13

    Joined:
    Apr 19, 2017
    Location:
    Toronto, Ontario, Canada
    #5
    I purchased season 8 of Game of Thrones on Monday. I watched it on an ATV 4K and my brother watched it on his ATV 3rd Gen. Both are running the latest tvOS and neither of us experienced this problem.
     
  6. JoelBC thread starter macrumors 6502a

    Joined:
    Jun 16, 2012
    #6
    Audit13, appreciate the response...I wonder why I am having this problem...I will try rebooting the Apple TVs to see whether or not that fixes the problem...thx for the feedback.
     
  7. Agent2015 macrumors 6502

    Agent2015

    Joined:
    Oct 17, 2015
    Location:
    Sonoran Desert
    #7
    During the tvOS 12.3 betas and with the official tvOS 12.3 the MLB app has been very erratic with the app exiting to the home screen within seconds or after a few minutes. However all other apps including HBO Now, Netflix, Amazon Prime, Apple Music and Movies are working working perfectly. I have reached out to MLB and they have yet to correct the issue.
     
  8. JoelBC thread starter macrumors 6502a

    Joined:
    Jun 16, 2012
    #8
    Wow, this seems very similar to the problem I am having...hopefully Apple will find a fix!
     
  9. niteflyr macrumors 6502a

    Joined:
    Nov 29, 2011
    Location:
    Southern Cal
    #9
    I'm one of those having similar issues with the MLB app. I have been binge watching the Breaking Bad Complete Series boxed set purchased on iTunes. I'm well into season 3 and have had no issues watching TV episodes.

    One thing came to mind today, and I downloaded the 12.4 tvOS beta and I'm running that now. I'll post here also if it solves the MLB app problem.
     
  10. Agent2015 macrumors 6502

    Agent2015

    Joined:
    Oct 17, 2015
    Location:
    Sonoran Desert
    #10
    I also tried the tvOS 12.4 beta 2 today. Unfortunately the MLB app still exits to the home screen on a random basis. I reported this behavior to MLB. Like you I am only having trouble with the MLB app as all other apps behave properly.
     
  11. niteflyr macrumors 6502a

    Joined:
    Nov 29, 2011
    Location:
    Southern Cal
    #11
    Same thing here, 12.4 no help. It's the MLB app. OP may want to try the beta. His issue is far different. I have not heard of anyone seeing his behavior. Maybe try a factory reset if that doesn't help.
     
  12. Donfor39 macrumors 65816

    Donfor39

    Joined:
    Jul 26, 2012
    Location:
    Lanarkshire Scotland
    #12
    Very happy with 12.4 restoring live tv via sky news app.
     

Share This Page

11 May 18, 2019