Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.

Nhott

macrumors regular
Original poster
Aug 5, 2014
117
55
When I select the TV app on the home screen, previews aren't showing. It happens on all of my AppleTVs and only using my profile. If I select my wife or kids profiles then it displays. Does anyone know if this is a bug or a setting I have deselected somewhere. I believe I have everything set the same as the other profiles.

My Profile:
2023-11-28_13-34-44.png


Wife's profile:
1701198724332.png
 
Last edited:

zobby

macrumors member
Jul 5, 2011
71
35
Yeah I have the same experience on the latest beta. Works once after a restart but then disappears.
 
  • Like
Reactions: Nhott

-Gonzo-

macrumors 65816
Nov 14, 2015
1,433
768
Wow, didn’t realise there were people out there that still have previews enabled on the homescreen.

It’s Up Next for me as find that much more beneficial.

IMG_3332.jpeg
 
  • Like
Reactions: seanrt

Nhott

macrumors regular
Original poster
Aug 5, 2014
117
55
Wow, didn’t realise there were people out there that still have previews enabled on the homescreen.

It’s Up Next for me as find that much more beneficial.
haha, yes we do still exist. I rarely watch anything on the actual TVs (using my profile) other than on family movie nights. When I switch to my profile I am usually looking to see if there is anything new that we can watch as family or also just the wife and I.

I tried that setting as well and it's also broken for my profile. :(
 

Nhott

macrumors regular
Original poster
Aug 5, 2014
117
55
Still broken on RC. I even factory wiped the AppleTV and set it back up.
 

Gator5000e

macrumors 6502a
Jan 27, 2018
896
781
Have you tried any of this:

Adjust settings for the Apple TV app​

  1. Open Settings
    5cad90d4eb83e1090648b8e99ad06ef3.png
    on Apple TV.
  2. Go to Apps > TV, then do any of the following:
    • Use your play history for personalized recommendations and Up Next: Turn on Use Play History.
    • Show or hide live sports scores: Turn Show Sports Scores on or off.
    • Choose the art you want to see in your Up Next watchlist: Select “Up Next Display,” then choose Still Frame to see still frames from what you’re watching, or Poster Art to show main title images for shows or movies.
    • Set what appears on the Home Screen when the Apple TV app is highlighted in the top row: Select “Top Shelf,” then choose What to Watch to see previews of featured TV shows and movies, or Up Next to see what’s in your personal queue.
    • Get Game Start and Close Game notifications for games you’ve added to Up Next: Turn on Games in Up Next.
    • Get notifications about recommended sports and events: Turn on Exciting Games.
    • Turn the sound on or off for background videos that automatically play in the Apple TV app: Turn Autoplay Video Sound on or off.
    • Set which Apple TV channels and apps share content with the Apple TV app: Select an app from the list to turn it on or off.
    • Remove information about what you’ve watched (which is synced with the Apple TV app on other devices): Select Clear Play History. This also removes TV shows and movies from Up Next
 

Gator5000e

macrumors 6502a
Jan 27, 2018
896
781
Or check the Accessibility Settings?

How to turn of auto-play previews on the Apple TV app​

Turning off the Apple TV apps's auto-play preview feature is super easy. Here's how.


Step 1: From the Settings menu, scroll down to and select Accessibility.

How to turn off auto-play previews on Apple TV: the Accessibility seoection.
Derek Malcolm / Digital Trends
Step 2: Scroll down again and select Motion.

How to turn off auto-play previews on Apple TV: the Motion selection.
Derek Malcolm / Digital Trends

Step 3: Lastly, scroll down to highlight Auto-Play Video Previews and click the remote to switch it from the On to Off.

How to turn off auto-play previews on Apple TV: switching it to the Off position.
Derek Malcolm / Digital Trends
That's it, that's all. That's just one of the little Apple TV tips and tricks we've covered at Digital Trends. Now you can enjoy your Apple TV on your own terms without those annoying previews playing.

Plus maybe check some of the other settings in the Accessibility settings section.
 

Nhott

macrumors regular
Original poster
Aug 5, 2014
117
55
Thanks for the tips. I just tried everything except clearing my play history. Right now I think I'm more okay with a broken home screen top shelf than losing my history. I'll run with this for now. Maybe it's something that will be fixed in a future update. I don't have the time right now to keep chasing this down.
 

Nhott

macrumors regular
Original poster
Aug 5, 2014
117
55
Update. I worked with Apple support a couple of weeks ago trying to fix my issue. They said no one else had reported it and would look into it. Well as of 17.3 beta 2, all is well.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.