tvOS changed so IR remote doesn't cause startup?

Discussion in 'Apple TV and Home Theater' started by MorphMan, Jun 12, 2016.

  1. MorphMan macrumors member

    Joined:
    Feb 20, 2013
    #1
    I've noticed my universal remote isn't causing the Apple TV (4) to turn on anymore.

    It works fine once on but previously pressing any button would wake it but now i have to pickup the real remote to wake it up.

    Has anyone else noticed this?
     
  2. benjitek macrumors 6502a

    benjitek

    Joined:
    Sep 23, 2012
  3. HobeSoundDarryl, Jun 12, 2016
    Last edited: Jun 13, 2016

    HobeSoundDarryl macrumors 603

    HobeSoundDarryl

    Joined:
    Feb 8, 2004
    Location:
    Hobe Sound, FL (20 miles north of Palm Beach)
    #3
    I just upgraded various AV equipment and re-programmed a third-party, "learning" universal remote to control it all. One thing I noticed with the "4" is that various functions that seemed to work with the "3" no longer worked the same. Worse, the new "4" remote doesn't appear to communicate an IR signal, so my universal couldn't "learn" the new codes from it. It appeared I was going to have to return to a 2-remote arrangement: the universal remote for controlling everything else and the "4" remote for controlling the "4."

    Ultimately, I solved the problem by replacing the former :apple:TV remote functions in my universal with an old VCR or DVR remote functions (like I had purchased an old VCR or DVR and wanted to program the universal for it), trying to replicate the various functions that can control the :apple:TV3. Then, I used the 4's "learn remote" function to learn those VCR commands to control it as I used to control the "3". While the reverse of how it usually goes with the learning remote- here making the device learn the remote IR signals instead of the remote learning the IR signals for any new device's remote- that worked and gave me full :apple:TV3-like control of the "4" which is what I was after... and "one remote to rule them all" again.
     
  4. ErikGrim macrumors 68040

    ErikGrim

    Joined:
    Jun 20, 2003
    Location:
    Brisbane, Australia
    #4
    I find that the functionality will simply disappear after a while. A restart of the AppleTV fixes it. HDMI-CEC is a hot mess, so I'm just thankful it works most of the time at all. My TV wasn't even supported at all until the 9.1 update.

    EDIT: Just noticed this was about IR remote turning on the ATV, not the remote turning on the TV.
     

Share This Page