Twain Driver

Discussion in 'Mac Basics and Help' started by In Utopia, Jul 12, 2010.

  1. In Utopia macrumors regular

    Joined:
    Aug 11, 2008
    #1
    I'm having trouble getting a Twain driver to install on my new imac.
    Have downloaded the right driver from Epson for a Perfection 610, but it won't load, try to load and the ball just keeps rotating.
    I also keep getting a message about opening from the website.

    Finally said installed, but can't find it in PE8.
     
  2. Makosuke macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #2
    I only have experience with the full Photoshop, not Elements, but Photoshop CS4 and CS5 do not support TWAIN by default; there is an optional plug-in that needs to be downloaded from Adobe and installed before you can use TWAIN acquire from within Photoshop.

    They did this, according to support, because they couldn't get TWAIN working reliably in new versions of PS, so it's a "run at your own risk--this may crash PS" deal. Which it does on a relatively regular basis, at least for me.

    Could be that PE8 has the same optional plugin available somewhere in the impenetrable labyrinth of Adobe's support site, or it could be TWAIN support was dropped entirely from Elements.
     
  3. In Utopia thread starter macrumors regular

    Joined:
    Aug 11, 2008
    #3
    I had to drill, but I did find the right driver and tried using it, but it was not recognized.
    It worked with a competitors software, but they don't have the features I want.
    Called Adobe and they passed me onto their forum.....thanks a lot for that.
     
  4. Makosuke macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #4
    Calling Adobe support useless is an insult to other ostensibly useless things, so I'm not surprised.

    Adobe forums are your best bet for finding an answer, though--I've had a lot more luck there than elsewhere with Adobe-specific questions.

    Good luck.
     

Share This Page