iPhone Tweak To Fix Cellular Data Settings

Discussion in 'Jailbreaks and iOS Hacks' started by we can swim, May 6, 2014.

  1. we can swim macrumors newbie

    Joined:
    Jan 26, 2014
    #1
    The app toggles of which can and can't use data won't save, more info here: https://discussions.apple.com/thread/5564798?start=0&tstart=0

    I have a feeling this could be fixed through iFile or Activator/Cydia but I do not know how. In that forum someone suggested editing the flags in /var/wireless/library/databases/CellularUsage.db but i could not edit the flags when i tried, could only edit the bundleid.

    Any ideas? I'm sure there are smarter people here then me or maybe there is already a tweak for this as it seems to be a common problem.
     
  2. Samanosuke macrumors 6502

    Joined:
    Mar 21, 2013
    #2
    You can manually put them in, but there is a reason they keep disappearing. What carrier are you on?
     
  3. we can swim thread starter macrumors newbie

    Joined:
    Jan 26, 2014
    #3
    How do I manually put them in?? Im on ATT but that shouldnt matter right?
     
  4. darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #4
    You can't manually input APN settings with AT&T as far as I know without some tweak(s)

    Have you tried a reset network settings?
     
  5. Samanosuke macrumors 6502

    Joined:
    Mar 21, 2013
    #5
    I had this exact issue with ATT, used tetherme to give me access to the apn settings, started playing with those and got the 5s I have working.
     
  6. issamela macrumors newbie

    Joined:
    May 7, 2014
    #6
    Finally after so long searchin i've found someone with a jailbreaked iphone and with the same problem, i'll give you one tip, don't delete your apps , i deleted mine and the cellular data problem was fixee but a few months later the problem somehow came back, so yesterday i deleted all my apps again, what seems? Even if i reinstall my apps the celullar data problem is still there, there should be a fix for this because it's driving me crazy the last couple of days i'm looking for solutions but nothint works, but like you say in a forum someone told me to edit the flags, i'm going to install itools on my pc and look if i can edit the flags on my pc because on my phone i can't, but yeah if you have a fix let me know, i'll keep you up to date if editing the flags on pc will help , thanks
     
  7. we can swim thread starter macrumors newbie

    Joined:
    Jan 26, 2014
    #7
    Ok thanks everyone, somehow I can finally use data for maps. But nothing else will use data. I will try downloading tether me when I get home to edit APN settings (even tho I don't really know what that means haha) this is very annoying :/
     
  8. braddick macrumors 68040

    braddick

    Joined:
    Jun 28, 2009
    Location:
    Encinitas, CA
    #8
    When my data sometimes goes out by switching SIM's into another iPhone I use (via WIFI), unlockit.co.nz and scroll to my carrier setup and within a moment or two am back in business.

    Might be worth the effort for you too.
     
  9. we can swim thread starter macrumors newbie

    Joined:
    Jan 26, 2014
    #9
    Ughhh nothing you guys suggested is working, anybody have any other ideas? I appreciate the suggestions though.
     
  10. Drivium macrumors newbie

    Joined:
    Feb 17, 2015
    #10
    I'm having the same problem. I started a thread here: http://www.sinfuliphone.com/showthread.php?p=1286505&posted=1#post1286505

    But that was before I discovered this one... Did you ever figure out what was causing this? Deleting apps brought your connection back? I have no data IP, yet, it says I'm on LTE. Is this what you guys are experiencing? I'm on Iphone 5 ios 6.1.2

    ----------

    What apn settings worked for you?
     

Share This Page