iPhone Tweak to fix missing wifi auto-join?

Discussion in 'Jailbreaks and iOS Hacks' started by DixonCox, Mar 6, 2013.

  1. DixonCox, Mar 6, 2013
    Last edited: Mar 6, 2013

    DixonCox macrumors newbie

    Mar 6, 2013
    I been having issues with wifi network at work whereby my iphone 5 wouldn't auto-join, and the option to auto-join is missing from the network settings.

    Is there a tweak to fix that? Been discussing these issues with some morons on another forum, so to address some possible questions:
    *the phone auto-joins most other networks just fine
    *ask to join is set to OFF
    *other devices, like my personal laptop running Win7 have no problems auto-connecting to that network
    *my co-workers' android phones have no problems auto-connecting to that network
    *I am not asked for password every time I connect--I only have to tap the network name in the list of available networks and it works--it just wouldn't do it automatically
    *I tried "forgetting" the network, entering network name/UID/PW manually--it didn't fix the issue

    Would much appreciate REAL advice or suggestions for a tweak that would fix this. Please don't tell me things like "iPhone does it natively, so there is no need for any tweak", "Apple knows best", etc.

    I'm attaching two screencap files--screencap1 is from my work wifi where the auto-join option is missing. screencap2 is from a local store's hotspot where it works as expected.

    Attached Files:

  2. BumpyFlatline macrumors 68030


    Apr 11, 2012
    Strange. Are the "auto-join" and "auto-login" features exclusively for the iPhone 5? Because I don't have those toggles on my 4S on 6.1.2. Weird.

    Sorry I'm not sure why your phone doesn't auto join. Ill do some searching in Cydia to see if I can find anything for you.
  3. llDeviousll macrumors newbie

    Mar 2, 2013
    Maybe try iWep PRO
  4. dextr3k macrumors 6502

    Nov 26, 2012
    I have never seen those 2 toggles before?

    iPhone 5 with 6.1
  5. DixonCox thread starter macrumors newbie

    Mar 6, 2013

Share This Page