Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

Tweetbot for Mac Updated With Support for macOS Sierra and Extended Tweets

MacRumors

macrumors bot
Original poster
Apr 12, 2001
50,386
11,757



Following the release of macOS Sierra moments ago, Tweetbot for Mac has been updated with support for the latest operating system. The update also includes support for extended tweets, uploading videos up to 140 seconds long to Twitter, and better media previews for search results.

In terms of extended tweets, Twitter no longer counts photos, videos, GIFs, polls, and quote tweets towards its 140-character limit. Previously, media content took up approximately 24 of the 140 available characters, and older versions of Tweetbot still enforce the 140 character limit accordingly.

Tweetbot for Mac version 2.4.2 is available now as a free update [Direct Link] for existing users on the Mac App Store. The app initially costs $9.99.

Article Link: Tweetbot for Mac Updated With Support for macOS Sierra and Extended Tweets
 

SandboxGeneral

Moderator emeritus
Sep 8, 2010
26,482
9,990
Detroit
Nice and quick of them to send out another update with the new character limits lifted so soon after they pushed an update the other day for iOS.
 
  • Like
Reactions: profets
Comment

zorinlynx

macrumors 603
May 31, 2007
6,278
9,623
Florida, USA
It's nice of Twitter to immediately provide an API for the longer tweets for third-party clients.

They've sorta been jerks towards third-party client authors, denying them APIs for things like finding out who favorited tweets, polls, certain notifications, images in direct messages, and so on.

Thanks for at least this, Twitter. :p
 
  • Like
Reactions: hobsgrg
Comment

Advil

macrumors 6502a
Oct 4, 2008
860
230
it's really buggy for me on sierra. icons aren't showing up and it's crashing when going to a profile. reinstalling now i guess.
 
Comment

SandboxGeneral

Moderator emeritus
Sep 8, 2010
26,482
9,990
Detroit
Huh. The update to Sierra and Tweetbot sure made Tweetbot crash several times upon launch and then the icons are all messed up...
Screen Shot 2016-09-20 at 4.56.15 PM.png
[doublepost=1474408004][/doublepost]If anyone gets the above issues I posted, run this in Terminal, as told to me by Tweetbot. It seems to have cleared up my problems so far.
Code:
rm -rf ~/Library/Containers/com.tapbots.TweetbotMac/Data/Library/Caches
 
Last edited:
Comment

4rtemidis

macrumors regular
Jun 20, 2012
167
8
Switzerland
Huh. The update to Sierra and Tweetbot sure made Tweetbot crash several times upon launch and then the icons are all messed up...
View attachment 655737
[doublepost=1474408004][/doublepost]If anyone gets the above issues I posted, run this in Terminal, as told to me by Tweetbot. It seems to have cleared up my problems so far.
Code:
rm -rf ~/Library/Containers/com.tapbots.TweetbotMac/Data/Library/Caches

Had the same issue, the terminal command fixed it! Thanks!
 
  • Like
Reactions: SandboxGeneral
Comment

lingaoyi

macrumors newbie
Jan 17, 2013
4
1
Huh. The update to Sierra and Tweetbot sure made Tweetbot crash several times upon launch and then the icons are all messed up...
View attachment 655737
[doublepost=1474408004][/doublepost]If anyone gets the above issues I posted, run this in Terminal, as told to me by Tweetbot. It seems to have cleared up my problems so far.
Code:
rm -rf ~/Library/Containers/com.tapbots.TweetbotMac/Data/Library/Caches

thx..........
 
  • Like
Reactions: SandboxGeneral
Comment

DavidNelsonNM

macrumors newbie
Sep 18, 2014
19
9
Albuquerque, NM
Huh. The update to Sierra and Tweetbot sure made Tweetbot crash several times upon launch and then the icons are all messed up...
View attachment 655737
[doublepost=1474408004][/doublepost]If anyone gets the above issues I posted, run this in Terminal, as told to me by Tweetbot. It seems to have cleared up my problems so far.
Code:
rm -rf ~/Library/Containers/com.tapbots.TweetbotMac/Data/Library/Caches


Tweetbot was crashing on me within 5 seconds of running it, this command fixed it. Thanks!
 
  • Like
Reactions: SandboxGeneral
Comment

TechPedia

macrumors newbie
Sep 12, 2006
6
1
Montgomery, Alabama
Has anyone see this? Started early in the Sierra beta, persists after the update. After some idle time (unknown, it varies) the content disappears. Restart required.
 

Attachments

  • screenshot_335.png
    screenshot_335.png
    196.1 KB · Views: 74
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.