Twitter Push Notifications on iPhone 5s

Discussion in 'iOS 7' started by ZachSpringman, Sep 25, 2013.

  1. ZachSpringman macrumors member

    Joined:
    Sep 25, 2013
    Location:
    Albany, NY
    #1
    Just got the iPhone 5s on launch day. For some reason every other app I installed gets push notifications - except the official Twitter app (receiving an alert as soon as I receive a mention/retweet/favorite). I've uninstalled, reinstalled, removed it from the notification center etc. and I cant get this app to receive any push notifications. My friend who has an iPhone 5 had the same issue, but after a while it began working for him.

    Has anyone experienced this or am I just missing something?
     
  2. Armen macrumors 604

    Armen

    Joined:
    Apr 30, 2013
    Location:
    127.0.0.1
    #2
    Silly question but have you tried looking in notification settings to see if Twitter is even allowed to send you notifications?
     
  3. ZachSpringman thread starter macrumors member

    Joined:
    Sep 25, 2013
    Location:
    Albany, NY
    #3
    Notification center would be where you enable apps to send you push notifications correct?

    ----------

    Notification center would be where you turn in push notifications for apps correct?
     
  4. Armen macrumors 604

    Armen

    Joined:
    Apr 30, 2013
    Location:
    127.0.0.1
    #4
    Settings > Notification Center.

    Scroll down until you find Twitter. Adjust how it notifiies you (Banner, Alert, Nothing, badges, sound, lock screen, etc)
     
  5. ZachSpringman thread starter macrumors member

    Joined:
    Sep 25, 2013
    Location:
    Albany, NY
    #5
    Everything is turned on, Alerts, Badge app icon, sounds, Alerts to show in notification center, and show on lock screen.
     
  6. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #6
    You'd want to check your notification settings for the app in notification center settings, as well as in the actual app settings inside of Twitter.
     
  7. Armen macrumors 604

    Armen

    Joined:
    Apr 30, 2013
    Location:
    127.0.0.1
    #7
    What CDM said. You have to also go to the twitter app and turn on notifications there too.
     
  8. ZachSpringman thread starter macrumors member

    Joined:
    Sep 25, 2013
    Location:
    Albany, NY
    #8
    They're all turned on within the app as well, as to why I'm so baffled that it isn't working.
     
  9. Armen macrumors 604

    Armen

    Joined:
    Apr 30, 2013
    Location:
    127.0.0.1
    #9
    IF you go to the people you follow you can individually enable mobile notifications from them. Check that as well.
     
  10. ZachSpringman thread starter macrumors member

    Joined:
    Sep 25, 2013
    Location:
    Albany, NY
    #10
    [​IMG][​IMG]

    Just to show you everything is on.
     
  11. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #11
    Have you tried disabling them in the Twitter app (perhaps for a good measure then sign out and sign back in) and then re-enabling them, perhaps even one or a few at a time to see if that might make any difference?
     
  12. ZachSpringman thread starter macrumors member

    Joined:
    Sep 25, 2013
    Location:
    Albany, NY
    #12
    I'll give that a try right now
     
  13. ZachSpringman thread starter macrumors member

    Joined:
    Sep 25, 2013
    Location:
    Albany, NY
    #14
    This is what happens when I try to disable them.[​IMG]
     
  14. ZachSpringman thread starter macrumors member

    Joined:
    Sep 25, 2013
    Location:
    Albany, NY
    #16
    Right but why would I have to go individually turn on notifications for each person? There should be a global setting that allows me to be alerted (not via text message) that someone or one of my followers favorited/retweeted/mentioned me.
     
  15. Armen macrumors 604

    Armen

    Joined:
    Apr 30, 2013
    Location:
    127.0.0.1
    #17
    Ask twitter? I haven't seen any way to apply that to all people at once.
     
  16. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #18
    That certainly doesn't seem right...and is probably related to why you are experiencing notification issues. Not quite sure what would cause that or what could be done to fix it unfortunately. Perhaps something about that kind of thing somewhere in Twitter help section online or some other threads/forums?
     
  17. ZachSpringman thread starter macrumors member

    Joined:
    Sep 25, 2013
    Location:
    Albany, NY
    #19
    Like I said below it should just work for everyone I shouldn't have to individually turn it on for each person. I just switched back to iPhone from android and all my friends with iPhones have never had this happen to them, so I'm just confused.

    ----------

    I guess that's the only option I have, I just wanted to make sure everyone here didn't think I was an idiot because I didn't have something turned on lol
     
  18. Armen macrumors 604

    Armen

    Joined:
    Apr 30, 2013
    Location:
    127.0.0.1
    #20
    dunno what to tell you. It's always been like that with the Twitter app. Maybe there is a way to turn on all mobile notifications from desktop twitter page? I don't use twitter too much so not sure.
     
  19. ZachSpringman thread starter macrumors member

    Joined:
    Sep 25, 2013
    Location:
    Albany, NY
    #21
    Yeah I tried online too but that turns on SMS alerts to your phone which is different. Thanks for the help though.
     
  20. D3TSURA macrumors member

    Joined:
    Mar 30, 2013
    #22
    I could think of a few possible reasons. The first being if a person has a lot of people that he's following then your phone is going to be constantly getting notifications which could be annoying. Also, if everyone had notifications turned on for everyone that they follow I would imagine that would possibly put a lot of strain on the push notification servers, so by doing it this way people are really most likely only going to select those whose tweets are most important to them.

    It would be nice to set batch notifications for people that you have in a list though.

    Edit:
    Also when I turned mine on it didn't seem to push notifications right away. It seemed like a couple hours after I turned them on I started to get alerts.
     
  21. ShiroiShimaTora macrumors newbie

    Joined:
    Jul 13, 2012
    Location:
    Virginia
    #23
    I had the same problem with Twitter on my 4S since iOS 6 came out. No DM notifications, no Mention notifications, no notifications at all. Though, after I changed my Twitter login password, notifications started working again.
     
  22. MorphinePH macrumors newbie

    Joined:
    Aug 31, 2014
    #24
    How to fix a not working Twitter push notification?

    Part 1: iPhone, iPad, iPod (Do the procedure on all of your devices.)

    1. Delete Twitter app.
    2. Go to Settings > Twitter > Select your username > Delete account.
    3. Reboot your device.

    Part 2: Desktop

    1. Go to www.twitter.com and sign in your account.
    2. Go to www.twitter.com/settings/applications
    3. You must see a list of applications that can access your twitter account.
    4. Click 'Revoke Access' on ALL of the apps.
    5. Refresh the page and you must not see any single app on the page.

    Part 3: iPhone, iPad, iPod (Do the procedure on all of your devices.)

    1. Go to Settings > Twitter > Add account
    2. Sign in your account.
    3. Install the Twitter app.

    PS: Sorry for my english, I'm from the Philippines.
     
  23. blingham macrumors newbie

    Joined:
    Dec 11, 2014
    #25
    As I haven't seen any activity here, or confirmation that MorphinePH's instructions work, I decided to post. I ran through the instructions on both my iPhone 5s, and my iPad Mini and it fully restored the Twitter notifications to perfect working order.

    I suspect this has something to do with the 25+ other app authorizations I had, and Twitter probably limiting push notifications to a subset of those.

    Thanks MorphinePH!
    Jay
     

Share This Page