Apps Two Apple TV's on the same network with the same user ID

sharkfin25

macrumors newbie
Original poster
Feb 12, 2020
3
0
Hi,

I just bought an additional Apple TV so that we don't have to move the original back and forth from the living room to the bedroom. I set up the new Apple TV to mirror the existing one and it was all good until we attempted to watch something. The Hulu app won't open at all. The Lifetime app opens and asks me to sign it with my provider. When I do, it say Success!, but never loads. All the apps work as expected on the original ATV. I have updated the software on the new ATV to the latest version. Anyone have a similar issue? If so, how did you resolve it?

Thanks!
 

cmaier

macrumors G5
Jul 25, 2007
14,966
9,805
California
Hi,

I just bought an additional Apple TV so that we don't have to move the original back and forth from the living room to the bedroom. I set up the new Apple TV to mirror the existing one and it was all good until we attempted to watch something. The Hulu app won't open at all. The Lifetime app opens and asks me to sign it with my provider. When I do, it say Success!, but never loads. All the apps work as expected on the original ATV. I have updated the software on the new ATV to the latest version. Anyone have a similar issue? If so, how did you resolve it?

Thanks!
Nope. I have three Apple TV’s here all setup with the same userids and providers and everything works fine. Try swapping them with each other and see if it has something to do with your network.
 

sharkfin25

macrumors newbie
Original poster
Feb 12, 2020
3
0
Nope. I have three Apple TV’s here all setup with the same userids and providers and everything works fine. Try swapping them with each other and see if it has something to do with your network.
I'll give it a try, but the new ATV is literally right in front of the router.

Thanks!
 

cmaier

macrumors G5
Jul 25, 2007
14,966
9,805
California
Also i assume you tried rebooting. When I first setup my most recent Apple tv 4K, a few apps wouldn’t launch. I ended up having to delete them and reinstall them.
 

sharkfin25

macrumors newbie
Original poster
Feb 12, 2020
3
0
Also i assume you tried rebooting. When I first setup my most recent Apple tv 4K, a few apps wouldn’t launch. I ended up having to delete them and reinstall them.
Yep! I just deleted the apps that weren't working and re-downloaded and they all seem to work now.

Thanks to everyone who replied!