Two finger swipe for back/forward not working in 10.13.1

Discussion in 'macOS High Sierra (10.13)' started by xraydoc, Nov 2, 2017.

  1. xraydoc macrumors demi-god

    xraydoc

    Joined:
    Oct 9, 2005
    Location:
    192.168.1.1
    #1
    Just installed 10.13.1 on my 2016 15" MBP with TouchBar.

    In Safari, I'm no longer able to use the two finger swipe gesture on my trackpad to go back or forward page by page.

    Safari looks like it's trying to go back or forward -- the animation starts but "gets stuck" and the page snaps back to where it started, so the back/forward never completes.

    Using the back/forward arrows in the Safari toolbar work as before.

    And yes, the gesture is turned on in the Trackpad system settings.

    It worked before 10.13.1 was installed -- not working after.

    Anyone else seeing this, too?
     
  2. kohlson macrumors 68000

    Joined:
    Apr 23, 2010
    #2
    Check your system preferences for Mouse and/or trackpad. They may have been reset with the update. Note that this works on my 2015 MBP.
     
  3. fisherking macrumors 604

    fisherking

    Joined:
    Jul 16, 2010
    Location:
    ny somewhere
    #3
    try rebooting, that fixed it for me (in one of the HS betas)...
     
  4. xraydoc thread starter macrumors demi-god

    xraydoc

    Joined:
    Oct 9, 2005
    Location:
    192.168.1.1
    #4
    Spontaneously started working correctly after waking the MBP from sleep. So strange. A reboot didn't do it but the trip home from work seemed to have fixed it. Very weird.
     
  5. Pennypacker83 macrumors regular

    Pennypacker83

    Joined:
    Dec 27, 2010
    Location:
    Helsinki, Finland
    #5
    This has been an issue on my 2015 rMBP ever since installing this piece of crapiola called HS. It seems to mostly occur when I have multiple apps and tabs open, and available memory is on the lower side. The 13.1 update did not fix this, but instead introduced another occasional issue -- now I cannot double-tap to zoom in Safari.
     
  6. fisherking macrumors 604

    fisherking

    Joined:
    Jul 16, 2010
    Location:
    ny somewhere
    #6
    these are not universal issues (neither thing is a problem here), so not a specific HS problem, but a problem you're having, and worth troubleshooting (since an OS update may not resolve it).
     
  7. Pennypacker83 macrumors regular

    Pennypacker83

    Joined:
    Dec 27, 2010
    Location:
    Helsinki, Finland
    #7
    Obviously the thread starter has the same issue with the two-finger swipe. It is also listed as a bug on this site. So I am not the only one. But hopefully the next update will fix these. Might have to do a full system reset though.
     
  8. fisherking macrumors 604

    fisherking

    Joined:
    Jul 16, 2010
    Location:
    ny somewhere
    #8

Share This Page

7 November 2, 2017