Two Finger Swipe Help! Firefox vs Lion

Discussion in 'Mac Apps and Mac App Store' started by iBuzzy, Jul 21, 2011.

  1. iBuzzy macrumors newbie

    Joined:
    Jul 21, 2011
    #1
    I have become very used to swiping with two fingers on a Magic Mouse to navigate through web pages in Firefox. I downloaded Lion today and when you swipe with two fingers, you switch between Mission Control Spaces. In system preferences, you cannot change the gesture for space switching -- the only option is "on" or "off".

    Does anyone have any suggestions for resolving this issue? The optimal solution would be to have the two finger swipe navigate pages in Firefox, whereas a three finger swipe, for instance, would correspond to Mission Control.

    Thanks!
     
  2. bocomo macrumors 6502

    Joined:
    Jun 29, 2007
    Location:
    New York
  3. Mitchelino macrumors 6502

    Joined:
    Jun 24, 2009
    Location:
    Ontario, Canada
  4. iBuzzy thread starter macrumors newbie

    Joined:
    Jul 21, 2011
    #4
    I'm using a Magic Mouse :(
     
  5. Mitchelino macrumors 6502

    Joined:
    Jun 24, 2009
    Location:
    Ontario, Canada
    #5
    My bad! System Preferences -> Mouse -> should be in there if it's a changeable option, which it should be.

    I don't have a mouse that I use, so I don't know the exact options inside.
     
  6. iBuzzy thread starter macrumors newbie

    Joined:
    Jul 21, 2011
    #6
    Unfortunately, no. There is only a "on" or "off" -- you cannot change the gesture.

    [​IMG]
     
  7. jive turkey macrumors 6502

    Joined:
    Mar 15, 2008
    #7
    On the trackpad the default is to fwd/bck by using four fingers. That might be difficult to do on a Magic Mouse I guess? I've never used the Magic Mouse so I can't give you any suggestions other than try 4 fingers.
     
  8. iBuzzy thread starter macrumors newbie

    Joined:
    Jul 21, 2011
    #8
    I can't figure out how to change the gesture for either command.
     
  9. midloman macrumors regular

    midloman

    Joined:
    Feb 10, 2010
    Location:
    Midllothian, VA
    #9
    2 Finger Swipe in Firefox and Chrome

    This problem is in Chrome as well. I also got very used to the 2 finger left and right swipe to cycle through my web pages; beats clicking the back and forward arrows. This only seems to work in Safari now. Trying it in other browsers seems like it's trying to that Mission Control or something. I have no interest in Mission Control at this point.

    Does anyone know of a way to get this to work for other browsers? I suppose one option would be try to set up some kind of custom gesture using Better Touch Tool or something, if that's possible.

    Hope someone figures out how to do this. I really, really got used to the 2 finger swipe.

    LT
     
  10. Ifni macrumors newbie

    Joined:
    May 16, 2009
    #10
    So did I. Fortunately, some Googling around introduced me to Better Touch Tool. It completely solves your problem by allowing you to customize gesture behavior. You have to tweak gesture sensitivity in the preferences to get it to behave more Snow-Leopard like, but other than that this program rocks. The download link says it only works with Snow Leopard, but the developer's blog link below indicates otherwise. All of us that love this gesture owe Andreas a huge thank you and a small Paypal donation!

    http://blog.boastr.net/

    David

    [Witty pop culture reference stolen from someone else]
     
  11. bcatic macrumors newbie

    Joined:
    Jul 22, 2011
    #11
    Open Mouse Preferences -> More Gestures. Click on the drop down menu under Swipe between pages and select Swipe left or right with two fingers.

    Enjoy...

    Ben
     
  12. tonewave macrumors newbie

    Joined:
    Jul 22, 2011
  13. iBuzzy thread starter macrumors newbie

    Joined:
    Jul 21, 2011
    #13
    Thanks so much!
     
  14. jive turkey macrumors 6502

    Joined:
    Mar 15, 2008
    #14
    I'm glad the preference change is working for you guys. I didn't bring it up last night because even by changing that setting I can't get two fingers to work in anything save Safari, and I've seen other people mention that on here as well. I thought it was a bug.
     
  15. bocomo macrumors 6502

    Joined:
    Jun 29, 2007
    Location:
    New York
    #15
    i guess it's up to Firefox devs to get it done

    even with adjusting the preferences, i can't three finger swipe to go back/forward or top/bottom of the page (with my MBP trackpad)
     
  16. kjmff5 macrumors regular

    Joined:
    Mar 27, 2011
    #16
    When going through Finder folders, does anyone know how to get the 3 finger swipe back a fold? Cant do it anymore....
     
  17. alfade macrumors newbie

    Joined:
    May 1, 2010
    #17
    thanks it works!!
     
  18. Max010 macrumors newbie

    Joined:
    Jul 25, 2011
    #18
    Hi there! I am just curious if someone else has this problem: I just did all the above and in the beginning all seemed to work pretty fine but then i noticed this:
    If u press cmd+u to show the page source (I use this since i am a developer) and then you press on a link inside the page source if you want to swipe back it does not work until you first scroll the page you just navigated to.

    This is the easiest way I found to replicate this problem, but I believe it also happens when opening new tabs(in normal view) and so on. This is getting very frustrating for me and I am afraid the people at apple or FF will not notice this.
    I would really appreciate it if anybody could confirm me this problem or at least tell me if you have had some unresponsivness with the three finger swipe in FF.:(
    Thank you!
    Cheers
     

Share This Page