Two iPhones and one Apple ID iMessage Trouble

Discussion in 'iPhone' started by TNigimoto, Sep 21, 2012.

  1. TNigimoto macrumors newbie

    Sep 21, 2012
    I'm wondering if there's anyone out there who has two iPhones and one Apple ID, as I am having problems with iMessage not activating on one.

    I was thinking that iMessage options for sending and receiving would be like this:
    Phone 1: Phone 1's #, Phone 2's #, Apple ID
    Phone 2: Phone 1's #, Phone 2's #, Apple ID

    However, my iPhones are like so:
    Phone 1: Phone 1's #, Apple ID
    Phone 2: Phone 1's #, Apple ID, Phone 2's # GREYED OUT

    Phone 2's number fails to activate. If it makes any difference, Phone 1 is an AT&T iPhone 4, and Phone 2 is an unlocked iPhone 4S (bought in the US), on Japan's NTT DoCoMo (an unsupported carrier).

    Prior to upgrading to iOS 6, I was able to send/receive messages on Phone 2 using Phone 2's phone number and Apple ID. I was also able to do so after upgrading, until I upgraded Phone 1 to iOS 6, and that is when Phone 1's number got "linked" to my Apple ID, and Phone 2's number will no longer activate.

    Is it possible to have two phone numbers linked, or unified, with one Apple ID?
  2. filmfanatic24 macrumors 6502

    Sep 5, 2007
    I have nothing to contribute but to say I'm going to try to do this very thing and if it doesn't work that might be a deal breaker for me.
  3. TNigimoto thread starter macrumors newbie

    Sep 21, 2012
    Please update after you try it!
  4. xAnthony macrumors 65816


    Mar 2, 2010
    Simple solution... Use two Apple ID's. Use ONE Apple ID for sharing/purchasing Apps. And then have the second user create their own Apple ID for iCloud. iMessage data falls under your iCloud account.
  5. cheezehead macrumors newbie


    Sep 13, 2012
    I ran into something similar with a pair of GSM 4 (non-S models) with a particular build of iOS 5. As we had unlimited texting, I just disabled iMessage as it was buggy.
  6. TNigimoto thread starter macrumors newbie

    Sep 21, 2012
    I do not want two Apple IDs, as I am the sole user and would like to use the same Apple ID for both iPhones, so I can receive iMessages on both phones via the same Apple ID.
  7. xAnthony macrumors 65816


    Mar 2, 2010
    Perhaps I misunderstood what you wrote. I heard something new about Apple linking phone numbers to Apple ID's to cause less problems if you forget your password and are trying to prove the Apple account actually belong to you.

    There was a thread earlier about a father who was receiving his kids iMessage's because their phones were linked under his Apple ID. Maybe try asking him.
  8. TNigimoto thread starter macrumors newbie

    Sep 21, 2012
    After researching a bit more and asking questions, apparently it is possible to have two phone numbers linked to one Apple ID, and people have been able to use both numbers and the Apple ID to send/receive messages.

    A few minutes ago I turned on/off iMessages on my Phone 1, which had been activated on iOS 6. Now that phone too is waiting for activation.

    Right now, both of my phones can use my Apple ID to send/receive messages, but can no longer use either phone number. Both phones show "waiting for activation."

    So, so strange.
  9. Mikes58 macrumors newbie

    Sep 21, 2012
    What a head ache . Both my wife and I have our iPhones liked to the one account on our home computer . iMessages worked perfectly and we could send messages to each other aswell as everyone else from our respective phones .

    Last night we updated both phones to iOS6 and it is a disaster ! iMessages is causing Havock.
    For a start when I send her a message I receive the same message instantly from myself . Both iMessage accounts have been linked to my phone number , we have to disable iMessages .

    Any solutions ?
  10. TNigimoto thread starter macrumors newbie

    Sep 21, 2012
    After updating to iOS 6, were both of your phone numbers showing up as a send/receive option, or just yours?

    You write that both iMessage accounts have been linked to your phone number, but was that because your wife's phone number was unavailable?

    If you have both phones linked to your phone number, any messages that you send to your wife will immediately come to you, as you describe. That's iMessage working as it should.
  11. BvW macrumors newbie

    Dec 27, 2012
    Same for me. In addition to the mobile given to me by my employer which I always carry I have a "private" phone number that I never carry with me, and I would like to be able to receive the occasional iMessage sent to the old private number of 17 years (almost all of my friends have iPhones) on my iPhone.

    Instead receiving iMessages sent to my work number and all my email addresses, I would also like to receive on the private number - and send from my work number.

    Is that possible?
  12. Jhwk macrumors newbie

    Feb 4, 2013
    Just found the fix, as both my wife and I have separate iphones on the same account.

    Settings > Messages
    scroll down on each phone to where it says Send & Receive and it should show a number. This is how many email accounts and phone numbers you can be contacted on, on each phone.

    Uncheck your spouses phone number on your phone and your phone number on their phone. Also uncheck any of her email addresses you don't use and do the same on her phone for your own email accounts.


    Too bad the phone doesn't keep these settings between OS updates.

Share This Page