Two Macs unable to see each other

Discussion in 'macOS' started by Kahnyl, Feb 28, 2010.

  1. Kahnyl macrumors 68000

    Joined:
    Feb 2, 2009
    #1
    I just got a new ZyXEL (P-660HW-T1 v3) router/modem from my ISP. I have it conneced to a D-Link router. Both have active wireless. When I have my Mac Mini and MacBook Pro connected to the D-Link they have no problem seeing each other. I have sharing enabled on the Mini so it just appears in the sidebar of the MacBook without any hassle. When I switch both to the ZyXEL they don't see each other. Internet works but the local network shows up as empty on both.

    Do I have to enable something on the new router or what?

    Thanks for reading.
     
  2. r0k macrumors 68040

    r0k

    Joined:
    Mar 3, 2008
    Location:
    Detroit
    #2
    Are the Mini and the Macbook Pro connecting wirelessly? Or is one ethernet and the other wireless?

    When they are both working, write down the ip address of both machines.

    When they are not working (on the Zyxel), write down the ip address of both machines.

    It is possible the Zyxel router has a setting which does not allow local file sharing via wifi. This setting should be able to be changed via a web browser. Put in the ip address of the Zyxel. This will be the gateway address when you are connected to the zyxel. To find out your own ip address in OS X, you can go to terminal and type ifconfig. You will get an entire list of ip addresses, some of which are 0.0.0.0 for interfaces that aren't connected to anything, but for the active interface you should see an ip address something like 192.168.1.15 with a gateway that is something like 192.168.1.1. The default admin password for a lot of routers is simply "admin". You should change this after logging in and write down what you change it to or the only way to regain control of your router will be a factory reset and you will have to set everything up all over again.

    Be sure to enable wpa or at least wep so your neighbors aren't able to use your wifi and look around your network. Most routers turn this on by default these days but it's still worth mentioning. Make up a passphrase you can remember rather than accepting the gobbledegook the router might offer as a default password. Some routers use their serial number as the default wifi password. This is fine. Just write it down so you have it handy when you need it on the other machines. Somewhere in the router settings there might be a setting to "allow local file sharing". You will need to enable this if it is disabled. Another possibility is that one machine is connecting wired at 192.168.1.x and the other is wireless at 192.168.3.x. In this case the cure is to set both wired and wireless networks to use the same subnet. Sorry to provide so much info but I'm trying to cover the basic reasons your machines can't see each other when connected to the zyxel.

    Hope this helps...
     

Share This Page