two MBP performance questions

Discussion in 'MacBook Pro' started by xenotaku, Oct 18, 2007.

  1. xenotaku macrumors regular

    Joined:
    Aug 30, 2005
    #1
    Hey all, I own a 2.2 Core 2 Duo 15" with 2GB ram.

    Some interesting things I have noticed lately. When I use expose to window all of my applications, the animation is very choppy and not fluid at all. It doesn't happen all the time, but it does happen more often than not. And the difference is VERY noticeable Secondly, I'm not sure which hardware component is located under the left speaker (or in that general area), but it seems like its working way too hard most of the time. I can feel it moving when I put my hand over the speaker. And that is usually in conjunction when expose is slow to respond as well. For instance, right now its working like a charm. Expose is quick and fluid, and my computer is quiet and nothing is churning under the speaker.

    Any ideas? Do I have a bum HD? It's embarrassing that expose responds better on my 5 year old PB than my 3 week old MBP.
     
  2. zioxide macrumors 603

    zioxide

    Joined:
    Dec 11, 2006
    #2
    My MBP runs expose fine, so yours most likely has an issue. The hard drive is located under the left palm rest, so that definitely could be the problem. You could try taking it in to the Apple store.
     
  3. xenotaku thread starter macrumors regular

    Joined:
    Aug 30, 2005
    #3
    It is more to the top....near the escape key. Not on the bottom of the left side.
     
  4. zioxide macrumors 603

    zioxide

    Joined:
    Dec 11, 2006
    #4
    hmm weird.. the only moving part up there is a fan.

    take it to the genius bar.
     

Share This Page