Two odd problems..

Discussion in 'iPhone' started by bc008, Jan 26, 2009.

  1. bc008 macrumors 68000

    bc008

    Joined:
    Aug 6, 2007
    Location:
    Michigan
    #1
    Problem 1:

    Sometimes my speaker doesn't work (not the loud "speaker phone" one, the one that is directly next to your ear) I can easily fix it by plugging in and unplugging my headphones. I think it may be because the headphones didn't toggle the switch that said they were unplugged or something.. any ideas?

    Problem 2:

    ac adaptor charging very unreliable. when I plug it in it shows the "low battery warning" so you think its charging. come back the next day to see its still dead. Works fine in my computer. (this is the newer "green dot" adapter)
     
  2. notintheleast macrumors 6502

    notintheleast

    Joined:
    Oct 1, 2008
    Location:
    NC
  3. andreab35 macrumors 6502a

    andreab35

    Joined:
    May 29, 2008
    Location:
    USA
    #3
    Wirelessly posted (iPhone: Mozilla/5.0 (iPhone; U; CPU iPhone OS 2_2 like Mac OS X; en-us) AppleWebKit/525.18.1 (KHTML, like Gecko) Version/3.1.1 Mobile/5G77 Safari/525.20)

    Yes, I agree to try and restore the phone, or even try restarting it first to see if that solves the issue.
    Good luck!
     
  4. AlecMyrddyn macrumors 6502

    Joined:
    Dec 5, 2008
    Location:
    Southern Maine
    #4
    I believe there is a small physical switch in the headphone jack that can get jammed by lint or other small debris that might have become lodged in the jack. It is quite likely that you can get things working better by cleaning out the headphone jack. Try a shot or two of compressed air first. A cut-down q-tip may also work.


    No idea. If you have an apple store close by, bring it in and see what they say.
     

Share This Page