Two-sided printing on Epson Workforce 840

Discussion in 'Mac Accessories' started by brianrunsphilly, Jun 3, 2014.

  1. brianrunsphilly macrumors newbie

    Joined:
    Jun 3, 2014
    #1
    Can't get it to work on my new MBP. It's grayed out. Laptop is fully up to date, just received it yesterday. Any suggestions? Double-sided printing is fine under Windows.
     
  2. colodane macrumors 6502a

    colodane

    Joined:
    Nov 11, 2012
    Location:
    Colorado
    #2
    I have a WorkForce 845, which I assume is somewhat similar.

    The two-sided printing has worked fine with my iMac for over 2 years now. However, the Epson menus on the Mac are indeed confusing and it can take awhile to get the printer working the way you desire. I don't claim to understand it all.

    Make sure you have the latest version of the Epson print utility. Then start trying the different options. One confusing thing is that the duplexing seems to be accessible from at least two different setting menus. I recall having to play with both of them before getting it to work. I have no experience with the printer on Windows so can't compare.
     
  3. brianrunsphilly thread starter macrumors newbie

    Joined:
    Jun 3, 2014
    #3
    Thanks. It was incredibly confusing. The option for two-sided printing should be on the print settings, but it's not. After around 20 minutes of digging I found it. Works perfectly now.
     
  4. mbrusso macrumors newbie

    Joined:
    Oct 22, 2015
    #4
     
  5. mbrusso macrumors newbie

    Joined:
    Oct 22, 2015
    #5
    Sorry, I am new to this forum, so there's a blank entry from me.

    So, I had iOS 8.4.x with a MacBook Pro. I have an Epson Workforce 845 All in One. I set it up with some driver originally when I got the laptop, I had to download it because no CD drive. So, it was all good, WI-FI worked, duplex worked. But I just recently upgraded to Yosemite, 10.10.x. Had to reinstall driver because every time I went to print something I lost WI-FI connection for my laptop so everything froze. Yes, that's fixed now with this "general Epson" driver I think I installed. However, 2 things now don't work. WI-FI printing, and duplex printing. Duplex is grayed out. Can't find any other mention of it in the dialog boxes. Should I start over and install the printer once again? The driver download page says I have the most current one??

    Thanks for any help you can provide.
     

Share This Page