Two unknown processes running and using my entire CPU.

Discussion in 'macOS' started by Sicarius, Sep 11, 2007.

  1. Sicarius macrumors member

    Joined:
    Oct 2, 2006
    Location:
    Tennessee.
    #1
    This has happened before, with an unknown widget. Now I have two processes "WindowServer" and "mds" each using at or around 50% of my CPU. This causes my fans to run all the time, and my computer to slow down noticeably. Does anyone know how I can remedy this? I've checked the Force Quit menu thing, and it doesn't show any application that would cause this problem.
     
  2. Super Macho Man macrumors 6502a

    Super Macho Man

    Joined:
    Jul 24, 2006
    Location:
    Hollywood, CA
    #2
  3. Krevnik macrumors 68030

    Krevnik

    Joined:
    Sep 8, 2003
    #3
    WindowServer is the process that runs the whole GUI. Kill that, and your pretty UI is now hung. It usually takes up a fair amount of CPU when /drawing/, but if there is nothing being drawn (no animations/etc) on the screen, it shouldn't take up any CPU at all.

    50% is a bit high for WindowServer in any case.
     
  4. ebel3003 macrumors 6502a

    ebel3003

    Joined:
    Jun 20, 2007
    Location:
    "The Google"
    #4


    WindowServer is necessary to the operating system. WindowServer, in a short and simple explanation, is what draws every object you see on the screen.
     
  5. yellow Moderator emeritus

    yellow

    Joined:
    Oct 21, 2003
    Location:
    Portland, OR
    #5
    Are you using Shapeshifter or any other UI "enhancement"?
     
  6. Eric Piercey macrumors 6502

    Eric Piercey

    Joined:
    Nov 29, 2006
    Location:
    Perpetual Bondage
    #6
    mds is the process for spotlight indexing. If it's going nuts and it isn't indexing you may have an issue. Does your spotlight work? Do some searches and see. I had a lot o problems when tiger first came out with Spotlight. Seems to work now though.
     

Share This Page