Two Updates Won't Install

Discussion in 'Mac Basics and Help' started by Sambo110, Jun 7, 2010.

  1. Sambo110 macrumors 68000

    Joined:
    Mar 12, 2007
    Location:
    Australia
    #1
    A security update (from like March or something) and Safari 5 just simply won't install. They are both downloaded, but when I click install it either shows a spinning loading thing for a few seconds, or the install thing for a few seconds, but then it just restarts. Would anyone know why it is doing this?
     
  2. patrick0brien macrumors 68040

    patrick0brien

    Joined:
    Oct 24, 2002
    Location:
    The West Loop
    #2
    I can think of a number of reasons.

    Let's start easy:
    Bad Permissions.
    Solution: Repair permissions
    Use Disk Utility to repair permissions on the VOLUME not just the partition within it. Click "Repair", not "Verify"

    Not so easy:
    Bad boot block, file tree mismatches, etc. If the previous doesn't work, you may need to use Disk Warrior, or, my favorite: TechTool to actually rebuild your disk and file structures. I find that pretty much solved all problems. But those softwares cost a little money.
     
  3. Compile 'em all macrumors 601

    Compile 'em all

    Joined:
    Apr 6, 2005
    #3
    Reboot and try again. I had kinda of a similar problem before and rebooting solved it.
     
  4. Sambo110 thread starter macrumors 68000

    Joined:
    Mar 12, 2007
    Location:
    Australia
    #4
    It wouldn't let me repair or verify the volume, only the OS X partition. I did that, will update this post if it works.

    EDIT: Repairing didn't work. I just remembered some updates installed properly, like 10.6.4
     
  5. vasanth4u macrumors member

    vasanth4u

    Joined:
    Jun 29, 2008
    #5
    Hiii

    Try to perform the Updates Manually from apple.com and check
     

Share This Page