Resolved TWTweetComposerView and Multiple Images

Discussion in 'iOS Programming' started by seepel, Jan 15, 2012.

  1. seepel, Jan 15, 2012
    Last edited: Jan 15, 2012

    seepel macrumors 6502

    seepel

    Joined:
    Dec 22, 2009
    #1
    I seem to be having a problem with TWTweetComposerView. It will let me add one image, however if I attempt to add another (via addImage) it will always return 0. I've verified that it is not a problem with the second image, by verifying that each image will upload individually. Here is the relevant code.

    Code:
    TWTweetComposeViewController *viewController = [[TWTweetComposeViewController alloc] init];
    NSLog(@"%d",[viewController setInitialText:@"My Message."]);
    NSLog(@"%d",[viewController addImage:image]);
    NSLog(@"%d",[viewController addImage:image2]);
    NSLog(@"%d",[viewController addImage:image3]);
    NSLog(@"%d",[viewController addImage:image4]);
    [self presentModalViewController:viewController animated:YES];
    
    which produces the output

    Code:
    2012-01-15 21:46:13.742 MyApp[3279:360f] 1
    2012-01-15 21:46:13.747 MyApp[3279:360f] 1
    2012-01-15 21:46:13.752 MyApp[3279:360f] 0
    2012-01-15 21:46:13.757 MyApp[3279:360f] 0
    2012-01-15 21:46:13.762 MyApp[3279:360f] 0
    
    Has anyone seen this before?
     
  2. seepel thread starter macrumors 6502

    seepel

    Joined:
    Dec 22, 2009
    #2
    And I finally found the help/configuration that returns the number of media items allowed in a tweet which has been reduced to 1 :(.
     

Share This Page